High
Security advisory
Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-9313
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 07:16 UTC · Revision 1
Source evidence
Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.
osv:CVE-2024-9313
Complete source record
{
"id": "719626b9461554d543d275adc45bd4ae6d2b6a83df2e1e12a2c37df0b9f08de9",
"url": "https://osv.dev/vulnerability/CVE-2024-9313",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2024-9313",
"summary": "Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.",
"evidence": "osv:CVE-2024-9313",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-9313",
"aliases": [
"CVE-2024-9313",
"GHSA-x5q3-c8rm-w787",
"GO-2024-3181"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/canonical/authd",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a31acc0a4e75a18b9eabc7e00532d4cbe8a7c1c9"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.3.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:canonical:authd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.3.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.3.3",
"v0.3.2",
"v0.2.1",
"v0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-9313.json"
}
}
],
"modified": "2026-10-28T02:30:26.740313872Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9313.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-9313",
"https://github.com/ubuntu/authd/security/advisories/GHSA-x5q3-c8rm-w787",
"https://www.cve.org/CVERecord?id=CVE-2024-9313",
"https://github.com/ubuntu/authd"
],
"provider_metadata": {
"cna_assigner": "canonical",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9313.json"
}
},
"related_cves": [
{
"value": "CVE-2024-9313",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 493320,
"published_at": "2024-10-03T11:04:00.474+00:00"
}