Skip to content
Heist/ feed
Back to feed
UnratedFix available

request-tracker4 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2011-2082

The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.

Products
request-tracker4
Affected versions
Not specified
Fixed versions
4.0.5-3
CVEs
CVE-2011-2082
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 23:11 UTC · Revision 1

Source evidence

DEBIAN-CVE-2011-2082

core-osv · Original source

Published 4 Jun 2012, 19:55 UTC

The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.

osv:DEBIAN-CVE-2011-2082

request-tracker4

Fixed versions: 4.0.5-3

Complete source record
{
  "id": "d7946004c7c823f38ee1a5e2a7c09965ff327d72e0face54014a1127602e644e",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-2082",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2011-2082",
    "summary": "The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.",
    "evidence": "osv:DEBIAN-CVE-2011-2082",
    "products": [
      {
        "name": {
          "value": "request-tracker4",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.0.5-3",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2011-2082",
      "aliases": [
        "DEBIAN-CVE-2011-2082"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.0.5-3"
                }
              ]
            }
          ],
          "package": {
            "name": "request-tracker4",
            "purl": "pkg:deb/debian/request-tracker4?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-2082.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T17:47:36.973937415Z",
      "provider": "osv",
      "upstream": [
        "CVE-2011-2082"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2011-2082"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2011-2082",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 417945,
  "published_at": "2012-06-04T19:55:01.54+00:00"
}