Skip to content
Heist/ feed
Back to feed
Medium

GetSimpleCMS-CE < 3.3.22 Stored XSS via components.php

Type: advisorySources: OSV

GetSimpleCMS Community Edition (CE) versions prior to 3.3.22 (3.3.16 tested) contains a stored cross-site scripting (XSS) vulnerability in the Theme to Components functionality within components.php. User-supplied input provided to the "slug" field of a component is stored without proper output encoding. While other fields are sanitized using safe_slash_html(), the slug parameter is written to XML and later rendered in the administrative interface without sanitation, resulting in persistent execution of arbitrary JavaScript. An authenticated administrator can inject malicious script content that executes whenever the affected Components page is viewed by any authenticated user, enabling session hijacking, unauthorized administrative actions, and persistent compromise of the CMS administrative interface.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-26351
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 05:50 UTC · Revision 1

Source evidence

GetSimpleCMS-CE < 3.3.22 Stored XSS via components.php

core-osv · Original source

Published 24 Feb 2026, 22:05 UTC

GetSimpleCMS Community Edition (CE) versions prior to 3.3.22 (3.3.16 tested) contains a stored cross-site scripting (XSS) vulnerability in the Theme to Components functionality within components.php. User-supplied input provided to the "slug" field of a component is stored without proper output encoding. While other fields are sanitized using safe_slash_html(), the slug parameter is written to XML and later rendered in the administrative interface without sanitation, resulting in persistent execution of arbitrary JavaScript. An authenticated administrator can inject malicious script content that executes whenever the affected Components page is viewed by any authenticated user, enabling session hijacking, unauthorized administrative actions, and persistent compromise of the CMS administrative interface.

osv:CVE-2026-26351
Complete source record
{
  "id": "10b25833285b66273b20da35dddbd61125ca2030ff5bd4f96083bbe1e4a1ec88",
  "url": "https://osv.dev/vulnerability/CVE-2026-26351",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "GetSimpleCMS-CE < 3.3.22 Stored XSS via components.php",
    "summary": "GetSimpleCMS Community Edition (CE) versions prior to 3.3.22 (3.3.16 tested) contains a stored cross-site scripting (XSS) vulnerability in the Theme to Components functionality within components.php. User-supplied input provided to the \"slug\" field of a component is stored without proper output encoding. While other fields are sanitized using safe_slash_html(), the slug parameter is written to XML and later rendered in the administrative interface without sanitation, resulting in persistent execution of arbitrary JavaScript. An authenticated administrator can inject malicious script content that executes whenever the affected Components page is viewed by any authenticated user, enabling session hijacking, unauthorized administrative actions, and persistent compromise of the CMS administrative interface.",
    "evidence": "osv:CVE-2026-26351",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-26351",
      "aliases": [
        "CVE-2026-26351",
        "GHSA-95f7-vm92-8gpx"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/getsimplecms-ce/getsimplecms-ce",
              "type": "GIT",
              "events": [
                {
                  "introduced": "52ec16906657c2b1fa530ff1d47cad7c30a7a5e1"
                },
                {
                  "fixed": "5486c10c75111e93404413fea6408f53dbffd930"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:community:*:*:*",
                    "range": [
                      {
                        "introduced": "3.3.16"
                      },
                      {
                        "fixed": "3.3.22"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "5486c10c75111e93404413fea6408f53dbffd930"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v3.3.22"
                  }
                ]
              }
            }
          ],
          "versions": [
            "3.3.16",
            "v3.3.21",
            "v3.3.17",
            "v3.3.18.1",
            "v3.3.16"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-26351.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.082238076Z",
      "provider": "osv",
      "references": [
        "https://getsimple-ce.ovh/",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/26xxx/CVE-2026-26351.json",
        "https://github.com/GetSimpleCMS-CE/GetSimpleCMS-CE/security/advisories/GHSA-95f7-vm92-8gpx",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-26351",
        "https://www.vulncheck.com/advisories/getsimplecms-ce-stored-xss-via-components-php",
        "https://github.com/GetSimpleCMS-CE/GetSimpleCMS-CE/releases/tag/v3.3.22",
        "https://github.com/GetSimpleCMS-CE/GetSimpleCMS-CE"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "VulnCheck",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/26xxx/CVE-2026-26351.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-26351",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 518405,
  "published_at": "2026-02-24T22:05:54.42+00:00"
}