HighFix available
underscore — security advisory
The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.
- Products
- underscore
- Affected versions
- Not specified
- Fixed versions
- 1.9.1~dfsg-2
- CVEs
- CVE-2021-23358
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:42 UTC · Revision 1
Source evidence
The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.
osv:DEBIAN-CVE-2021-23358
underscore
Fixed versions: 1.9.1~dfsg-2
underscore
Fixed versions: 1.9.1~dfsg-2
underscore
Fixed versions: 1.9.1~dfsg-2
Complete source record
{
"id": "0c0f812540b249db2f78ea2adffa0993c15839c2d6ddada9b5907ff0a1a3b2c8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-23358",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-23358",
"summary": "The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.",
"evidence": "osv:DEBIAN-CVE-2021-23358",
"products": [
{
"name": {
"value": "underscore",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.1~dfsg-2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "underscore",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.1~dfsg-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "underscore",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.1~dfsg-2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2021-23358",
"aliases": [
"DEBIAN-CVE-2021-23358"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.1~dfsg-2"
}
]
}
],
"package": {
"name": "underscore",
"purl": "pkg:deb/debian/underscore?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23358.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.1~dfsg-2"
}
]
}
],
"package": {
"name": "underscore",
"purl": "pkg:deb/debian/underscore?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23358.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.1~dfsg-2"
}
]
}
],
"package": {
"name": "underscore",
"purl": "pkg:deb/debian/underscore?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23358.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:37.169647783Z",
"provider": "osv",
"upstream": [
"CVE-2021-23358"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-23358"
]
},
"related_cves": [
{
"value": "CVE-2021-23358",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 422013,
"published_at": "2021-03-29T14:15:18.047+00:00"
}