Conda-build vulnerable to supply chain attack vector due to pyproject.toml referring to dependencies not present in PyPI
Conda-build contains commands and tools to build conda packages. Prior to version 25.3.0, the pyproject.toml lists conda-index as a Python dependency. This package is not published in PyPI. An attacker could claim this namespace and upload arbitrary (malicious) code to the package, and then exploit pip install commands by injecting the malicious dependency in the solve. This issue has been fixed in version 25.3.0. A workaround involves using --no-deps for pip install-ing the project from the repository.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-32800
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 02:03 UTC · Revision 1
Source evidence
Conda-build vulnerable to supply chain attack vector due to pyproject.toml referring to dependencies not present in PyPI
core-osv · Original sourcePublished 16 Jun 2025, 20:38 UTC
Conda-build contains commands and tools to build conda packages. Prior to version 25.3.0, the pyproject.toml lists conda-index as a Python dependency. This package is not published in PyPI. An attacker could claim this namespace and upload arbitrary (malicious) code to the package, and then exploit pip install commands by injecting the malicious dependency in the solve. This issue has been fixed in version 25.3.0. A workaround involves using --no-deps for pip install-ing the project from the repository.
osv:CVE-2025-32800
Complete source record
{
"id": "77c17d89316627a756116fecbbbfdf26c4d73500df2856a14b617abd38d0f868",
"url": "https://osv.dev/vulnerability/CVE-2025-32800",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Conda-build vulnerable to supply chain attack vector due to pyproject.toml referring to dependencies not present in PyPI",
"summary": "Conda-build contains commands and tools to build conda packages. Prior to version 25.3.0, the pyproject.toml lists conda-index as a Python dependency. This package is not published in PyPI. An attacker could claim this namespace and upload arbitrary (malicious) code to the package, and then exploit pip install commands by injecting the malicious dependency in the solve. This issue has been fixed in version 25.3.0. A workaround involves using --no-deps for pip install-ing the project from the repository.",
"evidence": "osv:CVE-2025-32800",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-32800",
"aliases": [
"CVE-2025-32800",
"GHSA-83gh-p93g-cwgx"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/conda/conda-build",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e77c4c6f9dc91c813dcfc0b8273f6a9864c7c5f3"
},
{
"fixed": "f5a6aeef0d5d6940b8c2a88796910dc7476a62bb"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:anaconda:conda-build:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "25.3.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "f5a6aeef0d5d6940b8c2a88796910dc7476a62bb"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"3.24.0",
"3.23.3",
"3.23.2",
"3.23.1",
"3.23.0",
"3.22.0",
"3.21.9",
"3.21.8",
"3.21.7",
"3.21.6",
"3.21.5",
"3.21.4",
"3.21.3",
"3.21.1",
"3.21.0",
"3.20.5",
"v3.20.4",
"3.20.3",
"3.20.1",
"3.20.0",
"3.19.3",
"3.19.2",
"3.19.1",
"3.19.0",
"3.18.12",
"3.18.10",
"3.18.9",
"3.18.7",
"3.18.8",
"3.18.6",
"3.18.5",
"3.18.4",
"3.18.3",
"3.18.2",
"3.18.1",
"3.18.0",
"3.17.7",
"3.17.8",
"3.17.6",
"3.17.5",
"3.17.4",
"3.17.3",
"3.17.2",
"3.17.1",
"3.17.0",
"3.16.3",
"3.16.2",
"3.13.0",
"3.16.1",
"3.16.0",
"3.15.1",
"3.15.0",
"3.14.4",
"3.14.3",
"3.14.2",
"3.14.1",
"3.14.0",
"3.12.1",
"3.12.0",
"3.11.0",
"3.10.9",
"3.10.8",
"3.10.7",
"3.10.6",
"3.10.5",
"3.10.4",
"3.10.3",
"3.10.2",
"3.10.1",
"3.10.0",
"3.9.2",
"3.9.1",
"3.9.0",
"3.8.0",
"3.8.1",
"3.7.2",
"3.7.1",
"3.4.2",
"3.7.0",
"3.6.0",
"3.5.1",
"3.5.0",
"3.4.1",
"3.4.0",
"3.3.0",
"3.2.2",
"3.2.1",
"3.2.0",
"3.1.6",
"3.1.5",
"3.1.4",
"3.1.3",
"3.1.2",
"3.1.1",
"3.1.0",
"3.0.31",
"3.0.30",
"3.0.29",
"3.0.28",
"3.0.27",
"3.0.26",
"3.0.25",
"3.0.24",
"3.0.23",
"3.0.22",
"3.0.21",
"3.0.20",
"3.0.19",
"3.0.18",
"3.0.17",
"3.0.16",
"3.0.15",
"3.0.14",
"3.0.13",
"3.0.12",
"3.0.11",
"3.0.10",
"3.0.9",
"3.0.8",
"3.0.7",
"3.0.6",
"3.0.5",
"3.0.4",
"3.0.3",
"3.0.2",
"3.0.1",
"3.0.0",
"3.0.0rc1",
"3.0.0rc0",
"3.0.0beta1",
"3.0.0beta0",
"3.0.0alpha3",
"3.0.0alpha2",
"3.0.0alpha1",
"2.1.5",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.1.0beta1",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"2.0.0",
"2.0.0beta4",
"2.0.0beta3",
"2.0.0beta2",
"1.20.2beta",
"2.0.0beta",
"1.20.3",
"1.20.3beta",
"1.20.2",
"1.20.1",
"1.20.0",
"1.19.2",
"1.19.1",
"1.19.0",
"1.18.2",
"1.18.1",
"1.18.0",
"1.17.0",
"1.16.0",
"1.14.1",
"1.14.0",
"1.13.0",
"1.11.0",
"1.10.0",
"1.9.0",
"1.8.2",
"1.8.0",
"1.7.1",
"1.2.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-32800.json"
}
}
],
"modified": "2026-10-28T02:30:53.020674500Z",
"provider": "osv",
"references": [
"https://drive.google.com/file/d/18qe97zxcpTn2l84187A9meGCi2Wg-n_Y/view",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32800.json",
"https://github.com/conda/conda-build/security/advisories/GHSA-83gh-p93g-cwgx",
"https://nvd.nist.gov/vuln/detail/CVE-2025-32800",
"https://github.com/conda/conda-build/commit/f5a6aeef0d5d6940b8c2a88796910dc7476a62bb"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1357"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32800.json"
}
},
"related_cves": [
{
"value": "CVE-2025-32800",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521600,
"published_at": "2025-06-16T20:38:53.1+00:00"
}