High
Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler
Type: advisorySources: OSV
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-39877
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 04:57 UTC · Revision 1
Source evidence
Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler
core-osv · Original sourcePublished 17 Jul 2024, 07:54 UTC
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
osv:CVE-2024-39877
Complete source record
{
"id": "01e0a74425e04862bcc058d24f5ab3b533ea9d148e9b1a59fbabccc92353453e",
"url": "https://osv.dev/vulnerability/CVE-2024-39877",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler",
"summary": "Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.",
"evidence": "osv:CVE-2024-39877",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-39877",
"aliases": [
"BIT-airflow-2024-39877",
"CVE-2024-39877",
"GHSA-g5hv-r743-v8pm",
"PYSEC-2024-190"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/airflow",
"type": "GIT",
"events": [
{
"introduced": "a0303486de970cc654bc12b62c8bee6a25e3382e"
},
{
"fixed": "cdf5d1e1b17b6269e8a5dc95aad4fbe344c05b9b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.9.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.9.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-39877.json"
}
}
],
"modified": "2026-10-28T02:30:33.217256663Z",
"provider": "osv",
"references": [
"https://pypi.python.org",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/39xxx/CVE-2024-39877.json",
"https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1",
"https://nvd.nist.gov/vuln/detail/CVE-2024-39877",
"https://github.com/apache/airflow/pull/40522"
],
"provider_metadata": {
"cwe_ids": [
"CWE-94"
],
"cna_assigner": "apache",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/39xxx/CVE-2024-39877.json"
}
},
"related_cves": [
{
"value": "CVE-2024-39877",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 500411,
"published_at": "2024-07-17T07:54:24.338+00:00"
}