Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-1999016

Pydio version 8.2.0 and earlier contains a Cross Site Scripting (XSS) vulnerability in ./core/vendor/meenie/javascript-packer/example-inline.php line 48; ./core/vendor/dapphp/securimage/examples/test.mysql.static.php lines: 114,118 that can result in an unauthenticated remote attacker manipulating the web client via XSS code injection. This attack appear to be exploitable via the victim openning a specially crafted URL. This vulnerability appears to have been fixed in version 8.2.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-1999016
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:46 UTC · Revision 1

Source evidence

CVE-2018-1999016

core-osv · Original source

Published 23 Jul 2018, 15:29 UTC

Pydio version 8.2.0 and earlier contains a Cross Site Scripting (XSS) vulnerability in ./core/vendor/meenie/javascript-packer/example-inline.php line 48; ./core/vendor/dapphp/securimage/examples/test.mysql.static.php lines: 114,118 that can result in an unauthenticated remote attacker manipulating the web client via XSS code injection. This attack appear to be exploitable via the victim openning a specially crafted URL. This vulnerability appears to have been fixed in version 8.2.1.

osv:CVE-2018-1999016
Complete source record
{
  "id": "a6039d259fbaa0e28bc9332b9263ff025f55411606794d10f17f83f9a8ebe8be",
  "url": "https://osv.dev/vulnerability/CVE-2018-1999016",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-1999016",
    "summary": "Pydio version 8.2.0 and earlier contains a Cross Site Scripting (XSS) vulnerability in ./core/vendor/meenie/javascript-packer/example-inline.php line 48; ./core/vendor/dapphp/securimage/examples/test.mysql.static.php lines: 114,118 that can result in an unauthenticated remote attacker manipulating the web client via XSS code injection. This attack appear to be exploitable via the victim openning a specially crafted URL. This vulnerability appears to have been fixed in version 8.2.1.",
    "evidence": "osv:CVE-2018-1999016",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2018-1999016",
      "aliases": [
        "CVE-2018-1999016"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/pydio/pydio-core",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "7dcdf8dd51636df8f9613db315e1c69eebc98ef8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:pydio:pydio:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "8.2.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "pydio-core-8.2.0",
            "pydio-core-8.0.1",
            "pydio-core-7.0.3",
            "pydio-core-7.0.2",
            "pydio-core-6.4.2",
            "pydio-core-6.4.2rc1",
            "pydio-core-6.4.1",
            "pydio-core-6.4.0",
            "pydio-core-6.4.0rc3",
            "pydio-core-6.4.0rc2",
            "pydio-core-6.4.0rc1",
            "pydio-core-6.2.2",
            "pydio-core-6.3.1",
            "pydio-core-6.2.2rc3",
            "pydio-core-6.2.2rc2",
            "pydio-core-6.2.2rc",
            "pydio-core-6.2.1",
            "pydio-core-6.2.0",
            "6.2rc",
            "pydio-core-6.0.8",
            "pydio-core-6.0.7",
            "pydio-core-5.2.5",
            "pydio-core-6.0.6",
            "pydio-core-6.0.5",
            "pydio-core-6.0.4",
            "pydio-core-6.0.3",
            "pydio-core-6.0.2",
            "pydio-core-6.0.1",
            "pydio-core-6.0.0",
            "pydio-core-5.2.4",
            "pydio-core-5.2.3",
            "pydio-core-5.2.2",
            "pydio-core-5.2.1",
            "pydio-core-5.2.0",
            "pydio-core-5.1.1",
            "pydio-core-5.1.0",
            "ajaxplorer-core-5.0.2",
            "ajaxplorer-core-5.0.1",
            "ajaxplorer-core-5.0.0",
            "ajaxplorer-core-4.3.4",
            "ajaxplorer-core-4.3.3",
            "ajaxplorer-core-4.3.2",
            "ajaxplorer-core-4.3.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1999016.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:44.218261543Z",
      "provider": "osv",
      "references": [
        "https://pydio.com/en/community/releases/pydio-core/pydio-821-security-release",
        "https://www.mike-gualtieri.com/files/Pydio-8-VulnerabilityDisclosure-Jul18.txt"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-1999016",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 435820,
  "published_at": "2018-07-23T15:29:00.547+00:00"
}