Skip to content
Heist/ feed
Back to feed
High

`tts-be` application has a Broken Access Control vulnerability

Type: advisorySources: OSV

`tts-be` is a backend for a timetable selector that aims to help students better choose their class schedules. Versions prior to 2.1.0 have a Broken Access Control vulnerability across several API endpoints (such as `/api/student/{id}/photo` and `/api/course_unit/{id}/exchange/metadata`). By chaining these unauthenticated endpoints, a remote attacker can use the backend as an open proxy to bypass authorization checks, allowing for the enumeration and extraction of sensitive Personally Identifiable Information (PII) from upstream university systems. The exposed data includes full names, student IDs, class schedules, and photos. This issue was fixed in version 2.1.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-88065
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 03:33 UTC · Revision 1

Source evidence

`tts-be` application has a Broken Access Control vulnerability

core-osv · Original source

Published 15 Sept 2026, 20:20 UTC

`tts-be` is a backend for a timetable selector that aims to help students better choose their class schedules. Versions prior to 2.1.0 have a Broken Access Control vulnerability across several API endpoints (such as `/api/student/{id}/photo` and `/api/course_unit/{id}/exchange/metadata`). By chaining these unauthenticated endpoints, a remote attacker can use the backend as an open proxy to bypass authorization checks, allowing for the enumeration and extraction of sensitive Personally Identifiable Information (PII) from upstream university systems. The exposed data includes full names, student IDs, class schedules, and photos. This issue was fixed in version 2.1.0.

osv:CVE-2026-88065
Complete source record
{
  "id": "20af8319ec3d1e21ddc85c96902f653ecdb38f54d4881885ed49353e32e5ed69",
  "url": "https://osv.dev/vulnerability/CVE-2026-88065",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "`tts-be` application has a Broken Access Control vulnerability",
    "summary": "`tts-be` is a backend for a timetable selector that aims to help students better choose their class schedules. Versions prior to 2.1.0 have a Broken Access Control vulnerability across several API endpoints (such as `/api/student/{id}/photo` and `/api/course_unit/{id}/exchange/metadata`). By chaining these unauthenticated endpoints, a remote attacker can use the backend as an open proxy to bypass authorization checks, allowing for the enumeration and extraction of sensitive Personally Identifiable Information (PII) from upstream university systems. The exposed data includes full names, student IDs, class schedules, and photos. This issue was fixed in version 2.1.0.",
    "evidence": "osv:CVE-2026-88065",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2026-88065",
      "aliases": [
        "CVE-2026-88065",
        "GHSA-fpfp-hr42-fvpm"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/niaefeup/tts-be",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "71324790c4cca9d59ac185417975df261987d700"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.1.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.1.0"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-88065.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:32.801192803Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/88xxx/CVE-2026-88065.json",
        "https://github.com/NIAEFEUP/tts-be/security/advisories/GHSA-fpfp-hr42-fvpm",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-88065"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-200",
          "CWE-306",
          "CWE-639"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/88xxx/CVE-2026-88065.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-88065",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 500044,
  "published_at": "2026-09-15T20:20:08.958+00:00"
}