WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter
WBCE CMS is a content management system. In versions 1.6.4 and below, the user management module allows a low-privileged authenticated user with permissions to modify users to execute arbitrary SQL queries. This can be escalated to a full database compromise, data exfiltration, effectively bypassing all security controls. The vulnerability exists in the admin/users/save.php script, which handles updates to user profiles. The script improperly processes the groups[] parameter sent from the user edit form. This issue is fixed in version 1.6.5.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-65950
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 18:59 UTC · Revision 1
Source evidence
WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter
core-osv · Original sourcePublished 10 Dec 2025, 20:39 UTC
WBCE CMS is a content management system. In versions 1.6.4 and below, the user management module allows a low-privileged authenticated user with permissions to modify users to execute arbitrary SQL queries. This can be escalated to a full database compromise, data exfiltration, effectively bypassing all security controls. The vulnerability exists in the admin/users/save.php script, which handles updates to user profiles. The script improperly processes the groups[] parameter sent from the user edit form. This issue is fixed in version 1.6.5.
osv:CVE-2025-65950
Complete source record
{
"id": "7708ae704892e778938b018aebace31999116be1c3898aa92238e53896f9d55e",
"url": "https://osv.dev/vulnerability/CVE-2025-65950",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter",
"summary": "WBCE CMS is a content management system. In versions 1.6.4 and below, the user management module allows a low-privileged authenticated user with permissions to modify users to execute arbitrary SQL queries. This can be escalated to a full database compromise, data exfiltration, effectively bypassing all security controls. The vulnerability exists in the admin/users/save.php script, which handles updates to user profiles. The script improperly processes the groups[] parameter sent from the user edit form. This issue is fixed in version 1.6.5.",
"evidence": "osv:CVE-2025-65950",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-65950",
"aliases": [
"CVE-2025-65950",
"GHSA-934v-xhx9-j2f3"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wbce/wbce_cms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "458d4385482770a7f6e77361e64265c1413b0c99"
},
{
"fixed": "96046178f4c80cf16f7c224054dec7fdadddda7e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wbce:wbce_cms:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.6.5"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "96046178f4c80cf16f7c224054dec7fdadddda7e"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "458d4385482770a7f6e77361e64265c1413b0c99"
}
],
"source": "REFERENCES_TAG",
"original_tag": "1.6.5"
}
]
}
}
],
"versions": [
"1.6.4",
"1.6.3",
"1.6.2",
"1.6.1",
"1.6.0",
"1.6.0-beta.4",
"1.6.0-beta.2",
"1.6.0-beta.1",
"1.5.4",
"1.5.3",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.0",
"1.3.2",
"1.3.1",
"1.3.0",
"1.2.0",
"1.1.11",
"1.1.10",
"1.1.9",
"1.1.8",
"1.1.6",
"1.1.4",
"1.1.3",
"1.1.2",
"1.1.1",
"1.1.0",
"1.0.0",
"1.0.0-rc.1",
"1.0.0-beta.3",
"1.0.0-beta.2",
"1.0.0-beta.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-65950.json"
}
}
],
"modified": "2026-10-28T02:30:48.089725280Z",
"provider": "osv",
"references": [
"https://github.com/WBCE/WBCE_CMS/releases/tag/1.6.5",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65950.json",
"https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-934v-xhx9-j2f3",
"https://nvd.nist.gov/vuln/detail/CVE-2025-65950",
"https://github.com/WBCE/WBCE_CMS/commit/96046178f4c80cf16f7c224054dec7fdadddda7e"
],
"provider_metadata": {
"cwe_ids": [
"CWE-89"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65950.json"
}
},
"related_cves": [
{
"value": "CVE-2025-65950",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 515931,
"published_at": "2025-12-10T20:39:27.452+00:00"
}