UnratedFix available
mediawiki — security advisory
Cross-site scripting (XSS) vulnerability in the AJAX module in MediaWiki before 1.6.9, 1.7 before 1.7.2, 1.8 before 1.8.3, and 1.9 before 1.9.0rc2, when wgUseAjax is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Products
- mediawiki
- Affected versions
- Not specified
- Fixed versions
- 1.7.1-6
- CVEs
- CVE-2007-0177
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 15:54 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in the AJAX module in MediaWiki before 1.6.9, 1.7 before 1.7.2, 1.8 before 1.8.3, and 1.9 before 1.9.0rc2, when wgUseAjax is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
osv:DEBIAN-CVE-2007-0177
mediawiki
Fixed versions: 1.7.1-6
mediawiki
Fixed versions: 1.7.1-6
mediawiki
Fixed versions: 1.7.1-6
Complete source record
{
"id": "0fc1233a245c68b1ecf8c805850e9af28200cbf9b5fef880e31ff5739145e438",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2007-0177",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2007-0177",
"summary": "Cross-site scripting (XSS) vulnerability in the AJAX module in MediaWiki before 1.6.9, 1.7 before 1.7.2, 1.8 before 1.8.3, and 1.9 before 1.9.0rc2, when wgUseAjax is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.",
"evidence": "osv:DEBIAN-CVE-2007-0177",
"products": [
{
"name": {
"value": "mediawiki",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.7.1-6",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mediawiki",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.7.1-6",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mediawiki",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.7.1-6",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2007-0177",
"aliases": [
"DEBIAN-CVE-2007-0177"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.1-6"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-0177.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.1-6"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-0177.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.1-6"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-0177.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
}
],
"modified": "2026-10-21T17:47:43.404942052Z",
"provider": "osv",
"upstream": [
"CVE-2007-0177"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2007-0177"
]
},
"related_cves": [
{
"value": "CVE-2007-0177",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 398529,
"published_at": "2007-01-11T00:28:00+00:00"
}