High
Security advisory
When the Elastic APM agent for Python versions before 5.1.0 is run as a CGI script, there is a variable name clash flaw if a remote attacker can control the proxy header. This could result in an attacker redirecting collected APM data to a proxy of their choosing.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-7617
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:32 UTC · Revision 1
Source evidence
When the Elastic APM agent for Python versions before 5.1.0 is run as a CGI script, there is a variable name clash flaw if a remote attacker can control the proxy header. This could result in an attacker redirecting collected APM data to a proxy of their choosing.
osv:CVE-2019-7617
Complete source record
{
"id": "0697c69de309fe84e40e1dd727c2ceb3a33f5051a7222153456b38827ee06ef0",
"url": "https://osv.dev/vulnerability/CVE-2019-7617",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-7617",
"summary": "When the Elastic APM agent for Python versions before 5.1.0 is run as a CGI script, there is a variable name clash flaw if a remote attacker can control the proxy header. This could result in an attacker redirecting collected APM data to a proxy of their choosing.",
"evidence": "osv:CVE-2019-7617",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2019-7617",
"aliases": [
"CVE-2019-7617",
"GHSA-22jh-6gx8-f944",
"PYSEC-2019-178"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/elastic/apm-agent-python",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "039d2917bfcb10dff8be8e1348096dc6b6d9dd13"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:elastic:apm_agent:*:*:*:*:*:python:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.1.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v5.0.0",
"v4.2.2",
"v4.2.1",
"v4.2.0",
"v4.1.0",
"v4.0.3",
"v4.0.2",
"v4.0.1",
"v4.0.0",
"v3.0.2",
"v3.0.1",
"v2.2.1",
"v3.0.0",
"v2.2.0",
"v2.1.1",
"v2.1.0",
"v2.0.1",
"v2.0.0",
"v1.0.0",
"v1.0.0.dev3",
"v1.0.0.dev2",
"v1.0.0.dev1",
"v1.0.0.dev0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-7617.json"
}
}
],
"modified": "2026-10-24T10:30:19.740113843Z",
"provider": "osv",
"references": [
"https://discuss.elastic.co/t/elastic-apm-agent-for-python-5-1-0-security-update/196145",
"https://www.elastic.co/community/security/"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-7617",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 430103,
"published_at": "2019-08-22T17:15:10.357+00:00"
}