Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass
Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-59845
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 16:04 UTC · Revision 1
Source evidence
Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass
core-osv · Original sourcePublished 26 Sept 2025, 22:38 UTC
Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.
osv:CVE-2025-59845
Complete source record
{
"id": "5048892e75d45aca019676ea7e0b5c376e33dabc04c86daf930b69c27eeb7b4c",
"url": "https://osv.dev/vulnerability/CVE-2025-59845",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass",
"summary": "Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.",
"evidence": "osv:CVE-2025-59845",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-59845",
"aliases": [
"CVE-2025-59845",
"GHSA-w87v-7w53-wwxv"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apollographql/embeddable-explorer",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e6d760d1635bae698abf1ad2a286761c4364491e"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.7.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "3.7.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
}
],
"versions": [
"@apollo/sandbox@2.7.1",
"@apollo/explorer@3.7.2",
"@apollo/explorer@3.7.1",
"@apollo/sandbox@2.7.0",
"@apollo/sandbox@2.6.0",
"@apollo/explorer@3.7.0",
"@apollo/sandbox@2.5.1",
"@apollo/explorer@3.6.0",
"@apollo/explorer-helpers@0.1.5",
"@apollo/sandbox@2.5.0",
"@apollo/explorer@3.5.0",
"@apollo/explorer-helpers@0.1.4",
"@apollo/explorer-helpers@0.1.2",
"@apollo/explorer-helpers@0.1.1",
"@apollo/sandbox@2.4.0",
"@apollo/explorer@3.4.0",
"@apollo/explorer-helpers@0.1.0",
"@apollo/sandbox@2.3.0",
"@apollo/explorer@3.3.0",
"@apollo/sandbox@2.2.0",
"@apollo/explorer@3.2.0",
"@apollo/sandbox@2.1.1",
"@apollo/explorer@3.1.1",
"@apollo/sandbox@2.1.0",
"@apollo/explorer@3.1.0",
"@apollo/sandbox@2.0.0",
"@apollo/explorer@3.0.0",
"@apollo/sandbox@1.0.3",
"@apollo/explorer@2.0.2",
"@apollo/sandbox@1.0.2",
"@apollo/explorer@2.0.1",
"@apollo/sandbox@1.0.1",
"@apollo/sandbox@1.0.0",
"@apollo/explorer@2.0.0",
"@apollo/sandbox@0.3.0",
"@apollo/explorer@1.2.0",
"@apollo/sandbox@0.2.1",
"@apollo/explorer@1.1.1",
"@apollo/sandbox@0.2.0",
"@apollo/explorer@1.1.0",
"@apollo/sandbox@0.1.0",
"@apollo/explorer@1.0.0",
"v0.6.0",
"v0.5.2",
"v0.5.1",
"v0.5.0",
"v0.4.2",
"v0.4.1",
"v0.4.0",
"v0.3.2",
"v0.3.1",
"v0.3.0",
"v0.2.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-59845.json"
}
}
],
"modified": "2026-10-28T02:30:30.313291391Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59845.json",
"https://github.com/apollographql/embeddable-explorer/security/advisories/GHSA-w87v-7w53-wwxv",
"https://nvd.nist.gov/vuln/detail/CVE-2025-59845"
],
"provider_metadata": {
"cwe_ids": [
"CWE-346",
"CWE-352"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59845.json"
}
},
"related_cves": [
{
"value": "CVE-2025-59845",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497111,
"published_at": "2025-09-26T22:38:57.35+00:00"
}