High
Security advisory
The Code Snippets plugin before 2.14.0 for WordPress allows CSRF because of the lack of a Referer check on the import menu.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-8417
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:04 UTC · Revision 1
Source evidence
The Code Snippets plugin before 2.14.0 for WordPress allows CSRF because of the lack of a Referer check on the import menu.
osv:CVE-2020-8417
Complete source record
{
"id": "7717b5e66c171ad7e81aab7a6dbd6ff59fbe337711f95b871e3b67031ef00357",
"url": "https://osv.dev/vulnerability/CVE-2020-8417",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-8417",
"summary": "The Code Snippets plugin before 2.14.0 for WordPress allows CSRF because of the lack of a Referer check on the import menu.",
"evidence": "osv:CVE-2020-8417",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2020-8417",
"aliases": [
"CVE-2020-8417"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/codesnippetspro/code-snippets",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "fef74ed671172f1e35112a93246c57b86713fd78"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:codesnippets:code_snippets:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.14.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.13.3",
"v2.13.2",
"v2.13.1",
"v2.13.0",
"v2.12.1",
"v2.12.0",
"v2.10.2",
"v2.10.1",
"v2.10.0",
"v2.9.6",
"v2.9.5",
"v2.9.4",
"v2.9.3",
"v2.9.2",
"v2.9.1",
"v2.9.0",
"v2.8.5",
"v2.8.4",
"v2.8.3",
"v2.8.2",
"v2.8.1",
"v2.8.0",
"v2.7.2",
"v2.7.1",
"v2.7.0",
"v2.6.1",
"v2.6.0",
"v2.5.1",
"v2.5.0",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.3.0",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.0",
"v1.8.0",
"v1.7.1.2",
"v1.7.1.1",
"v1.7.1",
"v1.7.0",
"v1.6.1",
"v1.6.0",
"v1.5.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-8417.json"
}
}
],
"modified": "2026-10-24T10:30:48.278708627Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins/code-snippets/#developers",
"https://wpvulndb.com/vulnerabilities/10050"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-8417",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 436730,
"published_at": "2020-01-28T21:15:11.903+00:00"
}