Skip to content
Heist/ feed
Back to feed
Medium

Auth0 Next.js SDK has Improper Proxy Cache Lookup

Type: advisorySources: OSV

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-40155
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 00:53 UTC · Revision 1

Source evidence

Auth0 Next.js SDK has Improper Proxy Cache Lookup

core-osv · Original source

Published 17 Apr 2026, 20:54 UTC

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.

osv:CVE-2026-40155
Complete source record
{
  "id": "a92264fe1a94e7ce740f57d4f219fad8e219ca3d882ffb07b356a9a7b870386a",
  "url": "https://osv.dev/vulnerability/CVE-2026-40155",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Auth0 Next.js SDK has Improper Proxy Cache Lookup",
    "summary": "The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.",
    "evidence": "osv:CVE-2026-40155",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-40155",
      "aliases": [
        "CVE-2026-40155",
        "GHSA-xq8m-7c5p-c2r6"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/auth0/nextjs-auth0",
              "type": "GIT",
              "events": [
                {
                  "introduced": "b44aa978deacd51fed1c68d8e44c4070d55cc7f7"
                },
                {
                  "fixed": "c4b39200c57524e24642c7eeddf6a7f2d929988b"
                },
                {
                  "fixed": "98c36dc306970c2230ea1a32efef431d29b99978"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:auth0:nextjs-auth0:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "4.12.0"
                      },
                      {
                        "fixed": "4.18.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "98c36dc306970c2230ea1a32efef431d29b99978"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "c4b39200c57524e24642c7eeddf6a7f2d929988b"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v4.18.0"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.17.1",
            "v4.17.0",
            "v4.16.2",
            "v4.16.1",
            "v4.16.0",
            "v4.15.0",
            "v4.14.1",
            "v4.14.0",
            "v4.13.2",
            "v4.13.3",
            "v4.13.1",
            "v4.13.0",
            "v4.12.1",
            "v4.12.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-40155.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:25.096787915Z",
      "provider": "osv",
      "references": [
        "https://github.com/auth0/nextjs-auth0/releases/tag/v4.18.0",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/40xxx/CVE-2026-40155.json",
        "https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-xq8m-7c5p-c2r6",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-40155",
        "https://github.com/auth0/nextjs-auth0/commit/98c36dc306970c2230ea1a32efef431d29b99978"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-362",
          "CWE-863"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/40xxx/CVE-2026-40155.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-40155",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 491342,
  "published_at": "2026-04-17T20:54:38.958+00:00"
}