Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-15142

Directory traversal in portal/import_template.php in versions of OpenEMR before 5.0.1.4 allows a remote attacker authenticated in the patient portal to execute arbitrary PHP code by writing a file with a PHP extension via the "docid" and "content" parameters and accessing it in the traversed directory.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-15142
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:27 UTC · Revision 1

Source evidence

CVE-2018-15142

core-osv · Original source

Published 13 Aug 2018, 18:29 UTC

Directory traversal in portal/import_template.php in versions of OpenEMR before 5.0.1.4 allows a remote attacker authenticated in the patient portal to execute arbitrary PHP code by writing a file with a PHP extension via the "docid" and "content" parameters and accessing it in the traversed directory.

osv:CVE-2018-15142
Complete source record
{
  "id": "c066b1b4068d623f64b1b515724659ff36e36986a99aea275f54e9c1b8c776b0",
  "url": "https://osv.dev/vulnerability/CVE-2018-15142",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-15142",
    "summary": "Directory traversal in portal/import_template.php in versions of OpenEMR before 5.0.1.4 allows a remote attacker authenticated in the patient portal to execute arbitrary PHP code by writing a file with a PHP extension via the \"docid\" and \"content\" parameters and accessing it in the traversed directory.",
    "evidence": "osv:CVE-2018-15142",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2018-15142",
      "aliases": [
        "CVE-2018-15142"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/openemr/openemr",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "8f6b1724e1a71df6a4c2ba0aeaf900a877b20546"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:open-emr:openemr:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.0.1.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v5_0_1_3",
            "v5_0_1_2",
            "v5_0_1_1",
            "v5_0_1",
            "v3_0_1",
            "v3_0_0",
            "v2_9_0",
            "v2_8_3",
            "v2_8_2",
            "v2_8_1",
            "v2_8_0",
            "v2_7_3-rc1",
            "v2_7_2",
            "v2_7_2-rc2",
            "v2_7_2-rc1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-15142.json"
          }
        }
      ],
      "modified": "2026-10-20T10:50:20.462538246Z",
      "provider": "osv",
      "references": [
        "https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/",
        "https://github.com/openemr/openemr/pull/1765/files",
        "https://www.exploit-db.com/exploits/45202/"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-15142",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 381570,
  "published_at": "2018-08-13T18:29:00.667+00:00"
}