multer vulnerable to Denial of Service via oversized array index in field names
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request with two specially crafted text field names can make multer's field parser synchronously iterate a maximum-length sparse array, blocking the event loop so the process cannot handle other requests. A large numeric array index in the first field allocates a maximum-length sparse array, and a second field with a non-numeric key then triggers a full-length iteration inside the append-field dependency. All versions before 2.3.0 are affected, and this is a remotely triggerable denial of service. multer 2.3.0 adds an opt-in fieldArrayIndexLimit option that rejects oversized array indexes. Upgrade to multer 2.3.0 and set limits.fieldArrayIndexLimit to the largest array index your application needs to remediate.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-82333
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 17:24 UTC · Revision 1
Source evidence
multer vulnerable to Denial of Service via oversized array index in field names
core-osv · Original sourcePublished 28 Aug 2026, 20:12 UTC
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request with two specially crafted text field names can make multer's field parser synchronously iterate a maximum-length sparse array, blocking the event loop so the process cannot handle other requests. A large numeric array index in the first field allocates a maximum-length sparse array, and a second field with a non-numeric key then triggers a full-length iteration inside the append-field dependency. All versions before 2.3.0 are affected, and this is a remotely triggerable denial of service. multer 2.3.0 adds an opt-in fieldArrayIndexLimit option that rejects oversized array indexes. Upgrade to multer 2.3.0 and set limits.fieldArrayIndexLimit to the largest array index your application needs to remediate.
osv:CVE-2026-82333
Complete source record
{
"id": "12d8f4abc2308578cc353bb0afb63a4ac61ba8a7f09c22790a7fecf301d0ae7d",
"url": "https://osv.dev/vulnerability/CVE-2026-82333",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "multer vulnerable to Denial of Service via oversized array index in field names",
"summary": "multer is a middleware for handling multipart/form-data in Node.js. A small multipart request with two specially crafted text field names can make multer's field parser synchronously iterate a maximum-length sparse array, blocking the event loop so the process cannot handle other requests. A large numeric array index in the first field allocates a maximum-length sparse array, and a second field with a non-numeric key then triggers a full-length iteration inside the append-field dependency. All versions before 2.3.0 are affected, and this is a remotely triggerable denial of service. multer 2.3.0 adds an opt-in fieldArrayIndexLimit option that rejects oversized array indexes. Upgrade to multer 2.3.0 and set limits.fieldArrayIndexLimit to the largest array index your application needs to remediate.",
"evidence": "osv:CVE-2026-82333",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-82333",
"aliases": [
"CVE-2026-82333",
"GHSA-535w-7cp7-47q4"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/expressjs/multer",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4e8edf50dbb5ddec213b6253642cbc08ce0225a7"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.3.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:expressjs:multer:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.3.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.2.0",
"v2.1.1",
"v2.1.0",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.4.5-lts.2",
"v1.4.5-lts.1",
"v1.4.4",
"v1.4.4-lts.1",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"v1.2.1",
"v1.2.0",
"v1.1.0",
"v1.0.6",
"v1.0.5",
"v1.0.4",
"v1.0.3",
"v1.0.2",
"v1.0.1",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-82333.json"
}
}
],
"modified": "2026-10-28T02:30:21.617206936Z",
"provider": "osv",
"references": [
"https://cna.openjsf.org/security-advisories.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/82xxx/CVE-2026-82333.json",
"https://github.com/expressjs/multer/security/advisories/GHSA-535w-7cp7-47q4",
"https://nvd.nist.gov/vuln/detail/CVE-2026-82333"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "openjs",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/82xxx/CVE-2026-82333.json"
}
},
"related_cves": [
{
"value": "CVE-2026-82333",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 487728,
"published_at": "2026-08-28T20:12:21.355+00:00"
}