Magento vulnerable to stored XSS in theme config fields
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-27400
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 15:40 UTC · Revision 1
Source evidence
Magento vulnerable to stored XSS in theme config fields
core-osv · Original sourcePublished 28 Feb 2025, 15:26 UTC
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
osv:CVE-2025-27400
Complete source record
{
"id": "cc9084983d3624e92ee0ab817558f71664197bff1ca8c74f4ac08d0f527d784a",
"url": "https://osv.dev/vulnerability/CVE-2025-27400",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Magento vulnerable to stored XSS in theme config fields",
"summary": "Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.",
"evidence": "osv:CVE-2025-27400",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2025-27400",
"aliases": [
"CVE-2025-27400",
"GHSA-5pxh-89cx-4668"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openmage/magento-lts",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4c2ef21b973d27ac1d89160610fec63f6436ab46"
},
{
"fixed": "d307e5bf75729a2347dde0952fe9fd9fcd9c6aea"
},
{
"fixed": "cd7bf930736a34add81b1fe84ba8caaca7e42b38"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "20.12.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "d307e5bf75729a2347dde0952fe9fd9fcd9c6aea"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "4c2ef21b973d27ac1d89160610fec63f6436ab46"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v20.12.3"
},
{
"range": [
{
"fixed": "cd7bf930736a34add81b1fe84ba8caaca7e42b38"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v20.13.0"
}
]
}
}
],
"versions": [
"v20.12.2",
"v20.12.1",
"v20.12.0",
"v20.11.0",
"v20.10.1",
"v21.0.0-beta2",
"v20.10.0",
"v20.9.0",
"v20.8.0",
"v20.7.0",
"v20.6.0",
"v20.5.0",
"v20.4.0",
"v20.3.0",
"v20.2.0",
"v20.1.1",
"v20.1.0",
"v20.1.0-rc7",
"v20.1.0-rc6",
"v20.1.0-rc5",
"v20.1.0-rc4",
"v20.1.0-rc3",
"v20.1.0-rc2",
"v20.1.0-rc1",
"v20.0.18",
"v20.0.17",
"v20.0.16",
"v20.0.15",
"v20.0.13",
"v20.0.12",
"v20.0.11",
"v20.0.10",
"v20.0.8",
"v20.0.7",
"v20.0.6",
"v20.0.5",
"v20.0.4",
"v20.0.3",
"v20.0.2",
"v20.0.1",
"v20.0.0",
"v19.4.4",
"v19.4.3",
"v19.4.2",
"v19.4.1",
"v19.4.0",
"1.9.0.1",
"1.9.1.1",
"1.9.1.0-lts",
"1.9.0.0",
"1.8.1.0",
"1.7.0.2",
"1.7.0.1",
"1.7.0.0",
"1.6.1.0",
"1.6.0.0",
"1.6.0.0-rc2",
"1.6.0.0-rc1",
"1.6.0.0-beta1",
"1.6.0.0-alpha1",
"1.5.1.0",
"1.5.0.1",
"1.5.0.0",
"1.5.0.0-rc2",
"1.5.0.0-rc1",
"1.5.0.0-beta2",
"1.5.0.0-beta1",
"1.5.0.0-alpha2",
"1.5.0.0-alpha1",
"1.4.2.0",
"1.4.1.1",
"1.4.1.0",
"1.4.0.1",
"1.3.2.4",
"1.4.0.0",
"1.4.0.0-rc1",
"1.4.0.0-beta1",
"1.4.0.0-alpha3",
"1.4.0.0-alpha2",
"1.4.0.0-alpha1",
"1.3.2.3",
"1.3.2.2",
"1.3.2.1",
"1.3.2",
"1.3.1.1",
"1.3.1",
"1.3.0",
"1.2.1.2",
"1.2.1",
"1.2.0.3",
"1.2.0.2",
"1.2.0.1",
"1.2.0",
"1.1.8",
"1.1.7",
"1.1.6",
"1.1.5",
"1.1.4",
"1.1.3",
"1.1.2",
"1.1.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-27400.json"
}
}
],
"modified": "2026-10-28T02:30:51.121234357Z",
"provider": "osv",
"references": [
"https://github.com/OpenMage/magento-lts/releases/tag/v20.12.3",
"https://github.com/OpenMage/magento-lts/releases/tag/v20.13.0",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/27xxx/CVE-2025-27400.json",
"https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5pxh-89cx-4668",
"https://nvd.nist.gov/vuln/detail/CVE-2025-27400",
"https://github.com/OpenMage/magento-lts/commit/d307e5bf75729a2347dde0952fe9fd9fcd9c6aea"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/27xxx/CVE-2025-27400.json"
}
},
"related_cves": [
{
"value": "CVE-2025-27400",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519784,
"published_at": "2025-02-28T15:26:14.265+00:00"
}