Critical
Security advisory
Jenkins GitHub Plugin 1.46.0 and earlier improperly processes the current job URL as part of JavaScript implementing validation of the feature "GitHub hook trigger for GITScm polling", resulting in a stored cross-site scripting (XSS) vulnerability exploitable by non-anonymous attackers with Overall/Read permission.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-42523
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:25 UTC · Revision 1
Source evidence
Jenkins GitHub Plugin 1.46.0 and earlier improperly processes the current job URL as part of JavaScript implementing validation of the feature "GitHub hook trigger for GITScm polling", resulting in a stored cross-site scripting (XSS) vulnerability exploitable by non-anonymous attackers with Overall/Read permission.
osv:CVE-2026-42523
Complete source record
{
"id": "b602060f7d75d2c6d3137970ae6d825df0e6a56027598296571191c36fe62614",
"url": "https://osv.dev/vulnerability/CVE-2026-42523",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2026-42523",
"summary": "Jenkins GitHub Plugin 1.46.0 and earlier improperly processes the current job URL as part of JavaScript implementing validation of the feature \"GitHub hook trigger for GITScm polling\", resulting in a stored cross-site scripting (XSS) vulnerability exploitable by non-anonymous attackers with Overall/Read permission.",
"evidence": "osv:CVE-2026-42523",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-42523",
"aliases": [
"CVE-2026-42523",
"GHSA-w22p-4x9f-486v"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jenkinsci/github-plugin",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "417b7dbbb12dd826696082fccf050989b5c28e0f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:jenkins:github:*:*:*:*:*:jenkins:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.46.0.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.46.0",
"v1.45.0",
"v1.44.0",
"v1.43.0",
"v1.42.0",
"v1.41.0",
"v1.40.0",
"v1.36.2",
"v1.39.0",
"v1.38.0",
"v1.37.3.1",
"v1.37.3",
"v1.37.2",
"v1.37.1",
"v1.37.0",
"v1.36.1",
"v1.36.0",
"v1.35.0",
"v1.34.5",
"v1.34.4",
"v1.34.3",
"v1.34.2",
"v1.34.1",
"v1.34.0",
"v1.33.1",
"v1.33.0",
"v1.32.0",
"v1.31.0",
"v1.29.5",
"v1.30.0",
"v1.29.4",
"v1.29.3",
"v1.29.0",
"v1.28.1",
"v1.28.0",
"v1.27.0",
"v1.26.2",
"v1.26.1",
"v1.26.0",
"v1.25.1",
"v1.24.0",
"v1.23.1",
"v1.23.0",
"v1.22.4",
"v1.22.3",
"v1.22.2",
"v1.22.1",
"v1.22.0",
"v1.21.1",
"v1.21.0",
"v1.20.0",
"v1.19.3",
"v1.19.2",
"v1.19.1",
"github-1.19.0",
"github-1.18.2",
"github-1.18.1",
"github-1.18.0",
"github-1.17.1",
"github-1.17.0",
"github-1.16.0",
"github-1.15.0",
"github-1.14.2",
"github-1.14.1",
"github-1.14.0",
"github-1.14.0-alpha-2",
"github-1.14.0-alpha-1",
"github-1.13.0",
"github-1.13.0-alpha-2",
"github-1.13.0-alpha-1",
"github-1.12.1",
"github-1.12.0",
"github-1.12.0-alpha-1",
"github-1.11.3",
"github-1.11.2",
"github-1.11.1",
"github-1.11",
"github-1.10",
"github-1.9.1",
"github-1.9",
"github-1.8",
"github-1.7",
"github-1.6",
"github-1.5",
"github-1.4",
"github-1.3",
"github-1.2",
"github-1.1",
"github-1.0",
"github-0.9",
"github-0.8",
"github-0.7",
"github-0.6",
"github-0.5",
"github-0.4",
"github-0.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-42523.json"
}
}
],
"modified": "2026-10-28T02:30:24.935703463Z",
"provider": "osv",
"references": [
"https://www.jenkins.io/security/advisory/2026-04-29/#SECURITY-3704"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2026-42523",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491623,
"published_at": "2026-04-29T14:16:19.36+00:00"
}