node-uri-js — security advisory
URI.js is a Javascript URL mutation library. Before version 1.19.9, whitespace characters are not removed from the beginning of the protocol, so URLs are not parsed properly. This issue has been patched in version 1.19.9. Removing leading whitespace from values before passing them to URI.parse can be used as a workaround.
- Products
- node-uri-js
- Affected versions
- 4.2.2+dfsg-4, 4.2.2+dfsg-5, 4.4.0+dfsg-10, 4.4.0+dfsg-5, 4.4.0+dfsg-7, 4.4.0+dfsg-8, 4.4.0+dfsg-9
- Fixed versions
- Not specified
- CVEs
- CVE-2022-24723
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 01:00 UTC · Revision 1
Source evidence
URI.js is a Javascript URL mutation library. Before version 1.19.9, whitespace characters are not removed from the beginning of the protocol, so URLs are not parsed properly. This issue has been patched in version 1.19.9. Removing leading whitespace from values before passing them to URI.parse can be used as a workaround.
osv:UBUNTU-CVE-2022-24723
node-uri-js
Fixed versions: Not specified
node-uri-js
Fixed versions: Not specified
node-uri-js
Fixed versions: Not specified
node-uri-js
Fixed versions: Not specified
node-uri-js
Fixed versions: Not specified
node-uri-js
Fixed versions: Not specified
Complete source record
{
"id": "d18c1ee77995df97bda85f8a918be6244e425ec97515082b51eb991ab57735a6",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-24723",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2022-24723",
"summary": "URI.js is a Javascript URL mutation library. Before version 1.19.9, whitespace characters are not removed from the beginning of the protocol, so URLs are not parsed properly. This issue has been patched in version 1.19.9. Removing leading whitespace from values before passing them to URI.parse can be used as a workaround.",
"evidence": "osv:UBUNTU-CVE-2022-24723",
"products": [
{
"name": {
"value": "node-uri-js",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.2.2+dfsg-4",
"evidence": "/affected/0/versions"
},
{
"value": "4.2.2+dfsg-5",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "node-uri-js",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.4.0+dfsg-5",
"evidence": "/affected/1/versions"
},
{
"value": "4.4.0+dfsg-7",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "node-uri-js",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.4.0+dfsg-8",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "node-uri-js",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.4.0+dfsg-8",
"evidence": "/affected/3/versions"
}
]
},
{
"name": {
"value": "node-uri-js",
"evidence": "/affected/4/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.4.0+dfsg-9",
"evidence": "/affected/4/versions"
},
{
"value": "4.4.0+dfsg-10",
"evidence": "/affected/4/versions"
}
]
},
{
"name": {
"value": "node-uri-js",
"evidence": "/affected/5/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.4.0+dfsg-8",
"evidence": "/affected/5/versions"
},
{
"value": "4.4.0+dfsg-9",
"evidence": "/affected/5/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2022-24723",
"aliases": [
"UBUNTU-CVE-2022-24723"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "low"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-uri-js",
"purl": "pkg:deb/ubuntu/node-uri-js?arch=source&distro=focal",
"ecosystem": "Ubuntu:20.04:LTS"
},
"versions": [
"4.2.2+dfsg-4",
"4.2.2+dfsg-5"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-24723.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-uri-js",
"binary_version": "4.2.2+dfsg-5"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-uri-js",
"purl": "pkg:deb/ubuntu/node-uri-js?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"4.4.0+dfsg-5",
"4.4.0+dfsg-7"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-24723.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-uri-js",
"binary_version": "4.4.0+dfsg-7"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-uri-js",
"purl": "pkg:deb/ubuntu/node-uri-js?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"4.4.0+dfsg-8"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-24723.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-uri-js",
"binary_version": "4.4.0+dfsg-8"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-uri-js",
"purl": "pkg:deb/ubuntu/node-uri-js?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"4.4.0+dfsg-8"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-24723.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-uri-js",
"binary_version": "4.4.0+dfsg-8"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-uri-js",
"purl": "pkg:deb/ubuntu/node-uri-js?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"4.4.0+dfsg-9",
"4.4.0+dfsg-10"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-24723.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-uri-js",
"binary_version": "4.4.0+dfsg-10"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-uri-js",
"purl": "pkg:deb/ubuntu/node-uri-js?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"4.4.0+dfsg-8",
"4.4.0+dfsg-9"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2022/UBUNTU-CVE-2022-24723.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-uri-js",
"binary_version": "4.4.0+dfsg-9"
}
]
}
}
],
"modified": "2026-10-17T12:56:21.587058656Z",
"provider": "osv",
"upstream": [
"CVE-2022-24723"
],
"references": [
"https://ubuntu.com/security/CVE-2022-24723",
"https://github.com/medialize/URI.js/security/advisories/GHSA-gmv4-r438-p67f",
"https://github.com/medialize/URI.js/releases/tag/v1.19.9",
"https://github.com/medialize/uri.js/commit/86d10523a6f6e8dc4300d99d671335ee362ad316",
"https://huntr.dev/bounties/82ef23b8-7025-49c9-b5fc-1bb9885788e5/",
"https://www.cve.org/CVERecord?id=CVE-2022-24723"
]
},
"related_cves": [
{
"value": "CVE-2022-24723",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 355410,
"published_at": "2022-03-03T21:15:00+00:00"
}