Security advisory
Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-32811
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:48 UTC · Revision 1
Source evidence
Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.
osv:CVE-2021-32811
Complete source record
{
"id": "bce428519d1d0c0379bea44bc2166f5b896b0a2b224fe7bffb0f42d09b79aab2",
"url": "https://osv.dev/vulnerability/CVE-2021-32811",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-32811",
"summary": "Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope \"Manager\" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.",
"evidence": "osv:CVE-2021-32811",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-32811",
"aliases": [
"CVE-2021-32811",
"GHSA-g4gq-j4p2-j8fr",
"PYSEC-2021-368",
"PYSEC-2021-370"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/zopefoundation/accesscontrol",
"type": "GIT",
"events": [
{
"introduced": "4acebba0ffe57e020c847acd84eed276dd9e1696"
},
{
"fixed": "f11416f52e5a09a521312ea20e78bbb17c7bf647"
},
{
"introduced": "b0123dcf9ed672444ef2b53802df2f48602fe60b"
},
{
"fixed": "e4fa02fd6f624283ec586d15d25230fc241d361d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:zope:accesscontrol:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.0"
},
{
"fixed": "4.3"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:zope:accesscontrol:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "5.0"
},
{
"fixed": "5.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"5.1",
"5.0",
"4.2",
"4.1",
"4.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-32811.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/zopefoundation/zope",
"type": "GIT",
"events": [
{
"introduced": "3a49c35fc8fc697bf0db747191ac4d9e737b9ccd"
},
{
"fixed": "67c557a8805e682192ea421848962385ae169e6c"
},
{
"introduced": "63f7ed59b82e973b6a44cb755837df7f787ff72b"
},
{
"fixed": "4e17a29856f80c82fdee61eadfda1b42fac92ffe"
},
{
"fixed": "f72a18dda8e9bf2aedb46168761668464a4be988"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.0"
},
{
"fixed": "4.6.3"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "5.0"
},
{
"fixed": "5.3"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "f72a18dda8e9bf2aedb46168761668464a4be988"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"4.6.2",
"4.6.1",
"5.2.1",
"4.6",
"5.2",
"5.1.2",
"4.5.5",
"5.1.1",
"4.5.4",
"4.5.3",
"5.1",
"4.5.2",
"5.0",
"4.5.1",
"4.5",
"4.4.4",
"4.4.3",
"4.4.2",
"4.4.1",
"4.4",
"4.3",
"4.2.1",
"4.2",
"4.1.3",
"4.1.2",
"4.1.1",
"4.1",
"4.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-32811.json"
}
}
],
"modified": "2026-10-24T10:50:13.209611597Z",
"provider": "osv",
"references": [
"https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-qcx9-j53g-ccgf",
"https://github.com/zopefoundation/Zope/security/advisories/GHSA-g4gq-j4p2-j8fr",
"https://github.com/zopefoundation/Zope/commit/f72a18dda8e9bf2aedb46168761668464a4be988"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-32811",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 442068,
"published_at": "2021-08-02T22:15:08.333+00:00"
}