Important: pcs security update
The pcs packages provide a command-line configuration system for the Pacemaker and Corosync utilities. Security Fix(es): * python-tornado: Tornado: Denial of Service via excessive URL-encoded body fields (CVE-2026-82397) * python-tornado: Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding (CVE-2024-14029) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
- Products
- pcs
- Affected versions
- Not specified
- Fixed versions
- 0:0.10.18-2.el8_10.10
- CVEs
- CVE-2024-14029, CVE-2026-82397
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 12:08 UTC · Revision 1
Source evidence
The pcs packages provide a command-line configuration system for the Pacemaker and Corosync utilities. Security Fix(es): * python-tornado: Tornado: Denial of Service via excessive URL-encoded body fields (CVE-2026-82397) * python-tornado: Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding (CVE-2024-14029) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
osv:RLSA-2026:84798
pcs
Fixed versions: 0:0.10.18-2.el8_10.10
Complete source record
{
"id": "3e922335e8b195de0418cb09b521fc8fe23acb267885d60e2d27d3b69d975bfd",
"url": "https://osv.dev/vulnerability/RLSA-2026%3A84798",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Important: pcs security update",
"summary": "The pcs packages provide a command-line configuration system for the Pacemaker and Corosync utilities. Security Fix(es): * python-tornado: Tornado: Denial of Service via excessive URL-encoded body fields (CVE-2026-82397) * python-tornado: Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding (CVE-2024-14029) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.",
"evidence": "osv:RLSA-2026:84798",
"products": [
{
"name": {
"value": "pcs",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0:0.10.18-2.el8_10.10",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "RLSA-2026:84798",
"aliases": [
"RLSA-2026:84798"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0:0.10.18-2.el8_10.10"
}
],
"database_specific": {
"yum_repository": "HighAvailability"
}
}
],
"package": {
"name": "pcs",
"purl": "pkg:rpm/rocky-linux/pcs?distro=rocky-linux-8&epoch=0",
"ecosystem": "Rocky Linux:8"
},
"database_specific": {
"source": "https://storage.googleapis.com/resf-osv-data/RLSA-2026:84798.json"
}
}
],
"modified": "2026-10-20T12:15:37.455854901Z",
"provider": "osv",
"upstream": [
"CVE-2024-14029",
"CVE-2026-82397"
],
"references": [
"https://errata.rockylinux.org/RLSA-2026:84798",
"https://bugzilla.redhat.com/show_bug.cgi?id=2526562",
"https://bugzilla.redhat.com/show_bug.cgi?id=2533918",
"https://access.redhat.com/errata/RHSA-2026:84798"
],
"provider_metadata": {
"license": "CC-BY-4.0",
"license_url": "https://creativecommons.org/licenses/by/4.0/",
"source_advisory": "RHSA-2026:84798"
}
},
"related_cves": [
{
"value": "CVE-2024-14029",
"evidence": "/upstream"
},
{
"value": "CVE-2026-82397",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 387263,
"published_at": "2026-10-20T12:01:38.477665+00:00"
}