Security advisory
galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2016-10560
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:16 UTC · Revision 1
Source evidence
galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
osv:CVE-2016-10560
Complete source record
{
"id": "240aa42e145292a1ff0ad8fa910d76f06da1e9fc4280d744ebd3cf55d0396bcc",
"url": "https://osv.dev/vulnerability/CVE-2016-10560",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2016-10560",
"summary": "galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.",
"evidence": "osv:CVE-2016-10560",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2016-10560",
"aliases": [
"CVE-2016-10560",
"GHSA-x5ph-4fr4-g7fw"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/hypery2k/galenframework-cli",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "11abe1ef450fc924b7081839a5665384f5640088"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:galenframework:galenframework-cli:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.3.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.2.6",
"v2.2.5",
"v2.2.4",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.10",
"v2.0.9",
"v2.0.8",
"v2.0.7",
"v2.0.6",
"v2.0.5",
"v2.0.4",
"v2.0.3",
"v1.6.4",
"v1.6.3",
"v1.6.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-10560.json"
}
}
],
"modified": "2026-10-24T10:30:16.159964943Z",
"provider": "osv",
"references": [
"https://nodesecurity.io/advisories/170"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2016-10560",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 429302,
"published_at": "2018-05-31T20:29:02.157+00:00"
}