High
WordPress Tainacan plugin <= 0.21.3 - Cross Site Scripting (XSS) vulnerability
Type: advisorySources: OSV
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tainacan Tainacan tainacan.This issue affects Tainacan: from n/a through <= 0.21.3.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-34794
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 14:09 UTC · Revision 1
Source evidence
WordPress Tainacan plugin <= 0.21.3 - Cross Site Scripting (XSS) vulnerability
core-osv · Original sourcePublished 3 Jun 2024, 10:50 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tainacan Tainacan tainacan.This issue affects Tainacan: from n/a through <= 0.21.3.
osv:CVE-2024-34794
Complete source record
{
"id": "27e589e33cfb60e785e5f8e8c2bf47b182121494ef68aaed61cf76e2873fe273",
"url": "https://osv.dev/vulnerability/CVE-2024-34794",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Tainacan plugin <= 0.21.3 - Cross Site Scripting (XSS) vulnerability",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tainacan Tainacan tainacan.This issue affects Tainacan: from n/a through <= 0.21.3.",
"evidence": "osv:CVE-2024-34794",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-34794",
"aliases": [
"CVE-2024-34794"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/tainacan/tainacan",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "7fc95777c79c52e6746eb038d5312cb533709a41"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:tainacan:tainacan:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.21.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"0.21.3",
"0.21.2",
"0.21.1",
"0.21.0",
"0.20.8",
"0.20.7",
"0.20.6",
"0.20.5",
"0.20.4",
"0.20.3",
"0.20.2",
"0.20.1",
"0.20.0",
"0.19.3",
"0.19.2",
"0.19.1",
"0.19",
"0.18.9",
"0.18.10",
"0.18.8",
"0.18.7",
"0.18.6",
"0.18.5",
"0.18.4",
"0.18.3",
"0.18.2",
"0.18.1",
"0.18",
"0.17.4",
"0.17.3",
"0.17.2",
"0.17.1",
"0.17",
"0.16.3",
"0.16.2",
"0.16.1",
"0.16",
"0.15.2",
"0.15",
"0.14.2",
"0.14.1",
"0.14",
"0.13.1",
"0.13",
"0.12",
"0.11",
"0.7",
"0.3",
"0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-34794.json"
}
}
],
"modified": "2026-10-28T02:30:36.069734360Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/34xxx/CVE-2024-34794.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-34794",
"https://patchstack.com/database/Wordpress/Plugin/tainacan/vulnerability/wordpress-tainacan-plugin-0-21-3-cross-site-scripting-xss-vulnerability?_s_id=cve",
"https://patchstack.com/database/vulnerability/tainacan/wordpress-tainacan-plugin-0-21-3-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "0.21.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/34xxx/CVE-2024-34794.json"
}
},
"related_cves": [
{
"value": "CVE-2024-34794",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503496,
"published_at": "2024-06-03T10:50:40.868+00:00"
}