Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-1999017

Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses "Check Now". This vulnerability appears to have been fixed in 8.2.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-1999017
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 08:07 UTC · Revision 1

Source evidence

CVE-2018-1999017

core-osv · Original source

Published 23 Jul 2018, 15:29 UTC

Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses "Check Now". This vulnerability appears to have been fixed in 8.2.1.

osv:CVE-2018-1999017
Complete source record
{
  "id": "0bf2c130d19f2b1fb435bd1c41ee01487a4c0ca49e9f49714597cdf585d2534e",
  "url": "https://osv.dev/vulnerability/CVE-2018-1999017",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-1999017",
    "summary": "Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses \"Check Now\". This vulnerability appears to have been fixed in 8.2.1.",
    "evidence": "osv:CVE-2018-1999017",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2018-1999017",
      "aliases": [
        "CVE-2018-1999017"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/pydio/pydio-core",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "7dcdf8dd51636df8f9613db315e1c69eebc98ef8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:pydio:pydio:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "8.2.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "pydio-core-8.2.0",
            "pydio-core-8.0.1",
            "pydio-core-7.0.3",
            "pydio-core-7.0.2",
            "pydio-core-6.4.2",
            "pydio-core-6.4.2rc1",
            "pydio-core-6.4.1",
            "pydio-core-6.4.0",
            "pydio-core-6.4.0rc3",
            "pydio-core-6.4.0rc2",
            "pydio-core-6.4.0rc1",
            "pydio-core-6.2.2",
            "pydio-core-6.3.1",
            "pydio-core-6.2.2rc3",
            "pydio-core-6.2.2rc2",
            "pydio-core-6.2.2rc",
            "pydio-core-6.2.1",
            "pydio-core-6.2.0",
            "6.2rc",
            "pydio-core-6.0.8",
            "pydio-core-6.0.7",
            "pydio-core-5.2.5",
            "pydio-core-6.0.6",
            "pydio-core-6.0.5",
            "pydio-core-6.0.4",
            "pydio-core-6.0.3",
            "pydio-core-6.0.2",
            "pydio-core-6.0.1",
            "pydio-core-6.0.0",
            "pydio-core-5.2.4",
            "pydio-core-5.2.3",
            "pydio-core-5.2.2",
            "pydio-core-5.2.1",
            "pydio-core-5.2.0",
            "pydio-core-5.1.1",
            "pydio-core-5.1.0",
            "ajaxplorer-core-5.0.2",
            "ajaxplorer-core-5.0.1",
            "ajaxplorer-core-5.0.0",
            "ajaxplorer-core-4.3.4",
            "ajaxplorer-core-4.3.3",
            "ajaxplorer-core-4.3.2",
            "ajaxplorer-core-4.3.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1999017.json"
          }
        }
      ],
      "modified": "2026-10-24T10:31:03.286940378Z",
      "provider": "osv",
      "references": [
        "https://pydio.com/en/community/releases/pydio-core/pydio-821-security-release",
        "https://www.mike-gualtieri.com/files/Pydio-8-VulnerabilityDisclosure-Jul18.txt"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-1999017",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 440218,
  "published_at": "2018-07-23T15:29:00.597+00:00"
}