High
Security advisory
In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21702
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:04 UTC · Revision 1
Source evidence
In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.
osv:CVE-2021-21702
Complete source record
{
"id": "520c344a1936a3caeff2145706f1bde53e030f62489fcfa082760c1cdf0999b7",
"url": "https://osv.dev/vulnerability/CVE-2021-21702",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21702",
"summary": "In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.",
"evidence": "osv:CVE-2021-21702",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-21702",
"aliases": [
"BIT-libphp-2021-21702",
"BIT-php-2021-21702",
"BIT-php-min-2021-21702",
"CVE-2021-21702"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/php/php-src",
"type": "GIT",
"events": [
{
"introduced": "52ace952a1b65ca80fc2617f11c2fa6dd03f51bd"
},
{
"fixed": "c800ecda065b5642dde6aff5484d58d91d77f66c"
},
{
"introduced": "3c7824e16ec4c3cee417262445d2c2b66531c10f"
},
{
"fixed": "c6723538054d96291abb6bad4628b9f55bc7fc17"
},
{
"introduced": "5dc92c2117cafc61daaaaa240fd46c3ac33872a4"
},
{
"fixed": "a66aeecc2c0adc32ea0bbaa6e669b92f2deaa939"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.3.0"
},
{
"fixed": "7.3.27"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.4.0"
},
{
"fixed": "7.4.15"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.0.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21702.json"
}
}
],
"modified": "2026-10-24T10:30:24.272114741Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2021/07/msg00008.html",
"https://security.gentoo.org/glsa/202105-23",
"https://security.netapp.com/advisory/ntap-20210312-0005/",
"https://www.debian.org/security/2021/dsa-4856",
"https://www.tenable.com/security/tns-2021-14",
"https://bugs.php.net/bug.php?id=80672",
"https://www.oracle.com/security-alerts/cpuoct2021.html"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:oracle:communications_diameter_signaling_router:*:*:*:*:*:*:*:*"
],
"vendor_product": "oracle:communications_diameter_signaling_router",
"extracted_events": [
{
"range": [
{
"introduced": "8.0.0"
},
{
"last_affected": "8.5.0"
}
],
"source": "CPE_RANGE"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
},
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-21702",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 431113,
"published_at": "2021-02-15T04:15:12.673+00:00"
}