Skip to content
Heist/ feed
Back to feed
MediumFix available

alsa-lib security update

Type: advisorySources: OSV

The alsa-lib is a library to interface with ALSA in the Linux kernel and virtual devices using a plugin system. More detail: https://alsa.opensrc.org/Alsa-lib Security Fix(es): alsa-lib through 1.2.16.1 computes combined topology element size using 32-bit arithmetic in src/topology/ctl.c, allowing integer overflow that defeats bounds checks. Attackers can supply crafted topology files that wrap size calculations, causing the decoder to read beyond the topology buffer and potentially leak sensitive data or crash the application.(CVE-2026-96674) alsa-lib through 1.2.16.1 contains a denial of service vulnerability in the multi PCM plugin that fails to validate sparse binding indices before array access. Attackers can supply a malicious ALSA configuration file with sparse bindings to trigger an out-of-bounds array read and assertion failure, causing the application to abort.(CVE-2026-96675)

Products
alsa-lib
Affected versions
Not specified
Fixed versions
1.2.10-7.oe2403sp1
CVEs
CVE-2026-96674, CVE-2026-96675
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 20:39 UTC · Revision 1

Source evidence

alsa-lib security update

core-osv · Original source

Published 16 Oct 2026, 11:59 UTC

The alsa-lib is a library to interface with ALSA in the Linux kernel and virtual devices using a plugin system. More detail: https://alsa.opensrc.org/Alsa-lib Security Fix(es): alsa-lib through 1.2.16.1 computes combined topology element size using 32-bit arithmetic in src/topology/ctl.c, allowing integer overflow that defeats bounds checks. Attackers can supply crafted topology files that wrap size calculations, causing the decoder to read beyond the topology buffer and potentially leak sensitive data or crash the application.(CVE-2026-96674) alsa-lib through 1.2.16.1 contains a denial of service vulnerability in the multi PCM plugin that fails to validate sparse binding indices before array access. Attackers can supply a malicious ALSA configuration file with sparse bindings to trigger an out-of-bounds array read and assertion failure, causing the application to abort.(CVE-2026-96675)

osv:OESA-2026-4312

alsa-lib

Fixed versions: 1.2.10-7.oe2403sp1

Complete source record
{
  "id": "72cbebf1a39ca2763301162ee59140f362aaaaf0a0b724b52ef5c191bf0ffa67",
  "url": "https://osv.dev/vulnerability/OESA-2026-4312",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "alsa-lib security update",
    "summary": "The alsa-lib is a library to interface with ALSA in the Linux kernel and virtual devices using a plugin system. More detail: https://alsa.opensrc.org/Alsa-lib Security Fix(es): alsa-lib through 1.2.16.1 computes combined topology element size using 32-bit arithmetic in src/topology/ctl.c, allowing integer overflow that defeats bounds checks. Attackers can supply crafted topology files that wrap size calculations, causing the decoder to read beyond the topology buffer and potentially leak sensitive data or crash the application.(CVE-2026-96674) alsa-lib through 1.2.16.1 contains a denial of service vulnerability in the multi PCM plugin that fails to validate sparse binding indices before array access. Attackers can supply a malicious ALSA configuration file with sparse bindings to trigger an out-of-bounds array read and assertion failure, causing the application to abort.(CVE-2026-96675)",
    "evidence": "osv:OESA-2026-4312",
    "products": [
      {
        "name": {
          "value": "alsa-lib",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.2.10-7.oe2403sp1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "OESA-2026-4312",
      "aliases": [
        "OESA-2026-4312"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.2.10-7.oe2403sp1"
                }
              ]
            }
          ],
          "package": {
            "name": "alsa-lib",
            "purl": "pkg:rpm/openEuler/alsa-lib&distro=openEuler-24.03-LTS-SP1",
            "ecosystem": "openEuler:24.03-LTS-SP1"
          },
          "database_specific": {
            "source": "https://repo.openeuler.org/security/data/osv/OESA-2026-4312.json"
          },
          "ecosystem_specific": {
            "src": [
              "alsa-lib-1.2.10-7.oe2403sp1.src.rpm"
            ],
            "noarch": [
              "alsa-topology-1.2.10-7.oe2403sp1.noarch.rpm",
              "alsa-ucm-1.2.10-7.oe2403sp1.noarch.rpm"
            ],
            "x86_64": [
              "alsa-lib-1.2.10-7.oe2403sp1.x86_64.rpm",
              "alsa-lib-debuginfo-1.2.10-7.oe2403sp1.x86_64.rpm",
              "alsa-lib-debugsource-1.2.10-7.oe2403sp1.x86_64.rpm",
              "alsa-lib-devel-1.2.10-7.oe2403sp1.x86_64.rpm"
            ],
            "aarch64": [
              "alsa-lib-1.2.10-7.oe2403sp1.aarch64.rpm",
              "alsa-lib-debuginfo-1.2.10-7.oe2403sp1.aarch64.rpm",
              "alsa-lib-debugsource-1.2.10-7.oe2403sp1.aarch64.rpm",
              "alsa-lib-devel-1.2.10-7.oe2403sp1.aarch64.rpm"
            ]
          }
        }
      ],
      "modified": "2026-10-16T12:15:08.980110511Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-96674",
        "CVE-2026-96675"
      ],
      "references": [
        "https://www.openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4312",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-96674",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-96675"
      ],
      "provider_metadata": {
        "severity": "Medium"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-96674",
        "evidence": "/upstream"
      },
      {
        "value": "CVE-2026-96675",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 340794,
  "published_at": "2026-10-16T11:59:14+00:00"
}