Skip to content
Heist/ feed
Back to feed
MediumFix available

py-openssl — security advisory

Type: advisorySources: OSVAdvisory ID: ALPINE-CVE-2018-1000808

Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.

Products
py-openssl
Affected versions
Not specified
Fixed versions
17.5.0-r0
CVEs
CVE-2018-1000808
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 22:09 UTC · Revision 1

Source evidence

ALPINE-CVE-2018-1000808

core-osv · Original source

Published 8 Oct 2018, 15:29 UTC

Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.

osv:ALPINE-CVE-2018-1000808

py-openssl

Fixed versions: 17.5.0-r0

py-openssl

Fixed versions: 17.5.0-r0

py-openssl

Fixed versions: 17.5.0-r0

Complete source record
{
  "id": "9a140324dfdb65d62e9f0f1e8482b917b109822e4f22dc4e9d602f8152299319",
  "url": "https://osv.dev/vulnerability/ALPINE-CVE-2018-1000808",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "ALPINE-CVE-2018-1000808",
    "summary": "Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.",
    "evidence": "osv:ALPINE-CVE-2018-1000808",
    "products": [
      {
        "name": {
          "value": "py-openssl",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "17.5.0-r0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "py-openssl",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "17.5.0-r0",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "py-openssl",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "17.5.0-r0",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "ALPINE-CVE-2018-1000808",
      "aliases": [
        "ALPINE-CVE-2018-1000808"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "17.5.0-r0"
                }
              ]
            }
          ],
          "package": {
            "name": "py-openssl",
            "purl": "pkg:apk/alpine/py-openssl?arch=source",
            "ecosystem": "Alpine:v3.6"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2018-1000808.json"
          },
          "ecosystem_specific": {}
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "17.5.0-r0"
                }
              ]
            }
          ],
          "package": {
            "name": "py-openssl",
            "purl": "pkg:apk/alpine/py-openssl?arch=source",
            "ecosystem": "Alpine:v3.7"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2018-1000808.json"
          },
          "ecosystem_specific": {}
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "17.5.0-r0"
                }
              ]
            }
          ],
          "package": {
            "name": "py-openssl",
            "purl": "pkg:apk/alpine/py-openssl?arch=source",
            "ecosystem": "Alpine:v3.8"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2018-1000808.json"
          },
          "ecosystem_specific": {}
        }
      ],
      "modified": "2026-10-23T17:23:37.708796678Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-1000808"
      ],
      "references": [
        "https://security.alpinelinux.org/vuln/CVE-2018-1000808"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-1000808",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 415736,
  "published_at": "2018-10-08T15:29:00.947+00:00"
}