Critical
NetAlertX Vulnerable to Authentication Bypass
Type: advisorySources: OSV
NetAlertX is a network, presence scanner and alert framework. Prior to version 25.4.14, it is possible to bypass the authentication mechanism of NetAlertX to update settings without authentication. An attacker can trigger sensitive functions within util.php by sending crafted requests to /index.php. This issue has been patched in version 25.4.14.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-32440
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 19:25 UTC · Revision 1
Source evidence
NetAlertX Vulnerable to Authentication Bypass
core-osv · Original sourcePublished 27 May 2025, 21:59 UTC
NetAlertX is a network, presence scanner and alert framework. Prior to version 25.4.14, it is possible to bypass the authentication mechanism of NetAlertX to update settings without authentication. An attacker can trigger sensitive functions within util.php by sending crafted requests to /index.php. This issue has been patched in version 25.4.14.
osv:CVE-2025-32440
Complete source record
{
"id": "186dca67a47fb6664ceaf3495fb91c6be9fc9454019e350848a663e9287b2995",
"url": "https://osv.dev/vulnerability/CVE-2025-32440",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "NetAlertX Vulnerable to Authentication Bypass",
"summary": "NetAlertX is a network, presence scanner and alert framework. Prior to version 25.4.14, it is possible to bypass the authentication mechanism of NetAlertX to update settings without authentication. An attacker can trigger sensitive functions within util.php by sending crafted requests to /index.php. This issue has been patched in version 25.4.14.",
"evidence": "osv:CVE-2025-32440",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-32440",
"aliases": [
"CVE-2025-32440",
"GHSA-h4x5-vr54-vjrx"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/netalertx/NetAlertX",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4bb87fe8dfc51f9cf9c4cd236dc8f70935a6d4db"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "25.4.14"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "4bb87fe8dfc51f9cf9c4cd236dc8f70935a6d4db"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v25.4.14"
}
]
}
}
],
"versions": [
"v25.4.1",
"v25.3.1",
"v25.1.19",
"v24.1.19",
"v25.1.8",
"v24.10.31",
"v24.9.26",
"v24.9.12",
"v24.7.18",
"v24.6.8",
"v24.5.9",
"v24.3.19",
"v24.2.17",
"v24.2.16",
"v24.01.18",
"v23.12.16",
"v23.11.11",
"v23.10.2",
"v23.9.12",
"v23.9.11",
"v23.9.10",
"v23.7.22",
"v23.6.16",
"v23.5.7",
"v23.04.01",
"v23.03.11",
"v23.02.02",
"v23.01.22-HF02",
"23.01.22-HF01",
"v23.01.22",
"23.01.14",
"v23.01.02",
"v3.02",
"v3.00",
"v2.70",
"v2.61",
"v2.60",
"v2.56",
"v2.55",
"v2.52",
"v2.51",
"v2.50"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-32440.json"
}
}
],
"modified": "2026-10-28T02:30:22.984544253Z",
"provider": "osv",
"references": [
"https://github.com/jokob-sk/NetAlertX/releases/tag/v25.4.14",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32440.json",
"https://github.com/jokob-sk/NetAlertX/security/advisories/GHSA-h4x5-vr54-vjrx",
"https://nvd.nist.gov/vuln/detail/CVE-2025-32440"
],
"provider_metadata": {
"cwe_ids": [
"CWE-306"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32440.json"
}
},
"related_cves": [
{
"value": "CVE-2025-32440",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 489079,
"published_at": "2025-05-27T21:59:40.497+00:00"
}