Skip to content
Heist/ feed
Back to feed
HighFix available

qemu — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2021-20181

A race condition flaw was found in the 9pfs server implementation of QEMU up to and including 5.2.0. This flaw allows a malicious 9p client to cause a use-after-free error, potentially escalating their privileges on the system. The highest threat from this vulnerability is to confidentiality, integrity as well as system availability.

Products
qemu
Affected versions
Not specified
Fixed versions
1:5.2+dfsg-4
CVEs
CVE-2021-20181
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:32 UTC · Revision 1

Source evidence

DEBIAN-CVE-2021-20181

core-osv · Original source

Published 13 May 2021, 16:15 UTC

A race condition flaw was found in the 9pfs server implementation of QEMU up to and including 5.2.0. This flaw allows a malicious 9p client to cause a use-after-free error, potentially escalating their privileges on the system. The highest threat from this vulnerability is to confidentiality, integrity as well as system availability.

osv:DEBIAN-CVE-2021-20181

qemu

Fixed versions: 1:5.2+dfsg-4

qemu

Fixed versions: 1:5.2+dfsg-4

qemu

Fixed versions: 1:5.2+dfsg-4

Complete source record
{
  "id": "8d41b45455bde36c7dd407ea53353817fa58a83724fcab2a353100f18f17df30",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-20181",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2021-20181",
    "summary": "A race condition flaw was found in the 9pfs server implementation of QEMU up to and including 5.2.0. This flaw allows a malicious 9p client to cause a use-after-free error, potentially escalating their privileges on the system. The highest threat from this vulnerability is to confidentiality, integrity as well as system availability.",
    "evidence": "osv:DEBIAN-CVE-2021-20181",
    "products": [
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-4",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-4",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-4",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2021-20181",
      "aliases": [
        "DEBIAN-CVE-2021-20181"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-4"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-20181.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-4"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-20181.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-4"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-20181.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:24.191798357Z",
      "provider": "osv",
      "upstream": [
        "CVE-2021-20181"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2021-20181"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2021-20181",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 421389,
  "published_at": "2021-05-13T16:15:07.653+00:00"
}