Caddy vulnerable to cross-origin config application via local admin API /load (caddy)
Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, the local caddy admin API (default listen `127.0.0.1:2019`) exposes a state-changing `POST /load` endpoint that replaces the entire running configuration. When origin enforcement is not enabled (`enforce_origin` not configured), the admin endpoint accepts cross-origin requests (e.g., from attacker-controlled web content in a victim browser) and applies an attacker-supplied JSON config. This can change the admin listener settings and alter HTTP server behavior without user intent. Version 2.11.1 contains a fix for the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-27589
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 01:59 UTC · Revision 1
Source evidence
Caddy vulnerable to cross-origin config application via local admin API /load (caddy)
core-osv · Original sourcePublished 24 Feb 2026, 16:30 UTC
Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, the local caddy admin API (default listen `127.0.0.1:2019`) exposes a state-changing `POST /load` endpoint that replaces the entire running configuration. When origin enforcement is not enabled (`enforce_origin` not configured), the admin endpoint accepts cross-origin requests (e.g., from attacker-controlled web content in a victim browser) and applies an attacker-supplied JSON config. This can change the admin listener settings and alter HTTP server behavior without user intent. Version 2.11.1 contains a fix for the issue.
osv:CVE-2026-27589
Complete source record
{
"id": "0e9b80304133468c472ca0ee63decfeb170bfae8447b400b801018842174d877",
"url": "https://osv.dev/vulnerability/CVE-2026-27589",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Caddy vulnerable to cross-origin config application via local admin API /load (caddy)",
"summary": "Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, the local caddy admin API (default listen `127.0.0.1:2019`) exposes a state-changing `POST /load` endpoint that replaces the entire running configuration. When origin enforcement is not enabled (`enforce_origin` not configured), the admin endpoint accepts cross-origin requests (e.g., from attacker-controlled web content in a victim browser) and applies an attacker-supplied JSON config. This can change the admin listener settings and alter HTTP server behavior without user intent. Version 2.11.1 contains a fix for the issue.",
"evidence": "osv:CVE-2026-27589",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-27589",
"aliases": [
"CVE-2026-27589",
"GHSA-879p-475x-rqh2",
"GO-2026-4537"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/caddyserver/caddy",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6610e2f1bd8f54853006eefd3849c9965190e57f"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "6610e2f1bd8f54853006eefd3849c9965190e57f"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v2.11.1"
},
{
"cpe": "cpe:2.3:a:caddyserver:caddy:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.11.0",
"v2.11.0-beta.2",
"v2.11.0-beta.1",
"v2.10.2",
"v2.10.1",
"v2.10.0",
"v2.10.0-beta.4",
"v2.10.0-beta.3",
"v2.9.1",
"v2.10.0-beta.2",
"v2.10.0-beta.1",
"v2.9.0",
"v2.9.0-beta.3",
"v2.9.0-beta.2",
"v2.9.0-beta.1",
"v2.8.4",
"v2.8.3",
"v2.8.2",
"v2.8.1",
"v2.8.0",
"v2.8.0-rc.1",
"v2.8.0-beta.2",
"v2.8.0-beta.1",
"v2.7.5",
"v2.7.4",
"v2.7.3",
"v2.7.2",
"v2.7.1",
"v2.7.0",
"v2.7.0-beta.2",
"v2.7.0-beta.1",
"v2.6.4",
"v2.6.3",
"v2.6.2",
"v2.6.1",
"v2.6.0",
"v2.6.0-beta.5",
"v2.6.0-beta.4",
"v2.6.0-beta.3",
"v2.6.0-beta.2",
"v2.6.0-beta.1",
"v2.5.2",
"v2.5.1",
"v2.5.0",
"v2.5.0-rc.1",
"v2.5.0-beta.1",
"v2.4.6",
"v2.4.5",
"v2.4.4",
"v2.4.3",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.4.0-rc.1",
"v2.4.0-beta.2",
"v2.4.0-beta.1",
"v2.3.0-rc.2",
"v2.3.0",
"v2.3.0-rc.1",
"v2.3.0-beta.1",
"v2.2.3",
"v2.2.1",
"v2.2.0",
"v2.2.0-rc.3",
"v2.2.0-rc.2",
"v2.2.0-rc.1",
"v2.1.1",
"v2.1.0",
"v2.1.0-beta.2",
"v2.1.0-beta.1",
"v2.0.0",
"v2.0.0-rc.3",
"v2.0.0-rc.2",
"v2.0.0-rc.1",
"v2.0.0-beta.20",
"v2.0.0-beta.19",
"v2.0.0-beta.18",
"v2.0.0-beta.17",
"v2.0.0-beta.16",
"v2.0.0-beta.15",
"v2.0.0-beta.14",
"v2.0.0-beta.13",
"v2.0.0-beta12",
"v2.0.0-beta11",
"v2.0.0-beta10",
"v2.0.0-beta9",
"v2.0.0-beta8",
"v2.0.0-beta7",
"v2.0.0-beta6",
"v2.0.0-beta5",
"v2.0.0-beta4",
"v2.0.0-beta3",
"v2.0.0-beta2",
"v2.0.0-beta1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-27589.json"
}
}
],
"modified": "2026-10-28T02:30:32.438287694Z",
"provider": "osv",
"references": [
"https://github.com/caddyserver/caddy/releases/tag/v2.11.1",
"https://github.com/user-attachments/files/25079818/poc.zip",
"https://github.com/user-attachments/files/25079820/PR_DESCRIPTION.md",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27589.json",
"https://github.com/caddyserver/caddy/security/advisories/GHSA-879p-475x-rqh2",
"https://nvd.nist.gov/vuln/detail/CVE-2026-27589"
],
"provider_metadata": {
"cwe_ids": [
"CWE-352"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27589.json"
}
},
"related_cves": [
{
"value": "CVE-2026-27589",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 499520,
"published_at": "2026-02-24T16:30:52.016+00:00"
}