Skip to content
Heist/ feed
Back to feed
CriticalFix available

apache2 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-36760

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.

Products
apache2
Affected versions
Not specified
Fixed versions
2.4.55-1
CVEs
CVE-2022-36760
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:58 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-36760

core-osv · Original source

Published 17 Jan 2023, 20:15 UTC

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.

osv:DEBIAN-CVE-2022-36760

apache2

Fixed versions: 2.4.55-1

apache2

Fixed versions: 2.4.55-1

apache2

Fixed versions: 2.4.55-1

Complete source record
{
  "id": "bb1ff7787b802bc101152caa5eb867aa7a4b8e2e3d24ac83dca457d428f2413f",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-36760",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-36760",
    "summary": "Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.",
    "evidence": "osv:DEBIAN-CVE-2022-36760",
    "products": [
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.55-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.55-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.55-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2022-36760",
      "aliases": [
        "DEBIAN-CVE-2022-36760"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.55-1"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-36760.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.55-1"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-36760.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.55-1"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-36760.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:02:39.992272027Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-36760"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-36760"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-36760",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323913,
  "published_at": "2023-01-17T20:15:11.58+00:00"
}