Skip to content
Heist/ feed
Back to feed
Low

Apache NiFi: Incorrect Authorization for Configuration Verification Requests

Type: advisorySources: OSV

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-44911
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 10:51 UTC · Revision 1

Source evidence

Apache NiFi: Incorrect Authorization for Configuration Verification Requests

core-osv · Original source

Published 22 Jun 2026, 07:37 UTC

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

osv:CVE-2026-44911
Complete source record
{
  "id": "a308151db4cf21e187d7b5ea34cb3eca9a42dbd616244001acf110cbbf27585b",
  "url": "https://osv.dev/vulnerability/CVE-2026-44911",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache NiFi: Incorrect Authorization for Configuration Verification Requests",
    "summary": "Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.",
    "evidence": "osv:CVE-2026-44911",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2026-44911",
      "aliases": [
        "BIT-nifi-2026-44911",
        "CVE-2026-44911",
        "GHSA-qvj8-gwpm-4x49"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/AU:Y/R:U/V:C/RE:L/U:Amber"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/nifi",
              "type": "GIT",
              "events": [
                {
                  "introduced": "7fdc07cccdc0e23d4986557a9314e36859704a3b"
                },
                {
                  "fixed": "2baff691128fa782983fb79bb1087adff027a4c1"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.15.0"
                      },
                      {
                        "fixed": "2.10.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-44911.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.518906222Z",
      "provider": "osv",
      "references": [
        "https://repo.maven.apache.org/maven2",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44911.json",
        "https://lists.apache.org/thread/wrj3t4k2bwd2cztyp078f5kj3722qfzy",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-44911"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-863"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "1.15.0"
                  },
                  {
                    "last_affected": "2.9.0"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44911.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-44911",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 519053,
  "published_at": "2026-06-22T07:37:10.823+00:00"
}