Skip to content
Heist/ feed
Back to feed
High

Everest Forms (Pro) <= 1.9.4 - Unauthenticated Path Traversal to Arbitrary File Deletion

Type: advisorySources: OSV

The Everest Forms (Pro) plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the delete_entry_files() function in all versions up to, and including, 1.9.4. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The vulnerability requires an admin to trigger the deletion via deletion of a form entry and cannot be carried out by the attacker alone.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-5927
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 15:06 UTC · Revision 1

Source evidence

Everest Forms (Pro) <= 1.9.4 - Unauthenticated Path Traversal to Arbitrary File Deletion

core-osv · Original source

Published 25 Jun 2025, 09:21 UTC

The Everest Forms (Pro) plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the delete_entry_files() function in all versions up to, and including, 1.9.4. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The vulnerability requires an admin to trigger the deletion via deletion of a form entry and cannot be carried out by the attacker alone.

osv:CVE-2025-5927
Complete source record
{
  "id": "3365b5aa05971969be97ce473eba922b0222d6593f4e37595e1799ef6a32fbaa",
  "url": "https://osv.dev/vulnerability/CVE-2025-5927",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Everest Forms (Pro) <= 1.9.4 - Unauthenticated Path Traversal to Arbitrary File Deletion",
    "summary": "The Everest Forms (Pro) plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the delete_entry_files() function in all versions up to, and including, 1.9.4. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The vulnerability requires an admin to trigger the deletion via deletion of a form entry and cannot be carried out by the attacker alone.",
    "evidence": "osv:CVE-2025-5927",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-5927",
      "aliases": [
        "CVE-2025-5927"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/themegrill/everest-forms",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "7ed9f9513d7ec2d41994244fedae689b7ca5da57"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wpeverest:everest_forms:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.9.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.9.4.1",
            "1.9.4",
            "1.9.3",
            "1.9.2",
            "1.9.1",
            "1.9.0.1",
            "1.9.0",
            "1.8.9",
            "1.8.8",
            "1.8.7",
            "1.8.6",
            "1.8.5",
            "1.8.4",
            "1.8.3",
            "1.8.2.3",
            "1.8.2.2",
            "1.8.2.1",
            "1.8.2",
            "1.8.1",
            "1.8.0.1",
            "1.8.0",
            "1.7.9",
            "1.7.8",
            "1.7.7.2",
            "1.7.7.1",
            "1.7.7",
            "1.7.6",
            "1.7.5.2",
            "1.7.5.1",
            "1.7.5",
            "1.7.4",
            "1.7.3",
            "1.7.2.2",
            "1.7.2.1",
            "1.7.2",
            "1.7.1",
            "1.7.0.3",
            "1.7.0.2",
            "1.7.0.1",
            "1.7.0",
            "1.6.7",
            "1.6.6.1",
            "1.6.6",
            "1.6.5",
            "1.6.4",
            "1.6.2",
            "1.6.3",
            "1.6.1",
            "1.6.0",
            "1.5.10",
            "1.5.9",
            "1.5.8",
            "1.5.7",
            "1.5.6",
            "1.5.5",
            "1.5.4",
            "1.5.2",
            "1.5.1",
            "1.5.0",
            "1.4.9",
            "1.4.8",
            "1.4.6",
            "1.4.5",
            "1.4.4",
            "1.4.3",
            "1.4.2",
            "1.4.1",
            "1.4.0-beta6",
            "1.4.0",
            "1.4.0-beta5",
            "1.4.0-beta4",
            "1.4.0-beta3",
            "1.4.0-beta2",
            "v1.4.0-beta",
            "1.4.0-beta",
            "1.3.4",
            "1.3.2",
            "1.3.0",
            "1.2.0",
            "1.2.0-rc.1",
            "1.1.4",
            "1.1.3",
            "1.1.0",
            "1.1.0-rc.1",
            "1.0.2",
            "1.0.1",
            "1.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-5927.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:36.624113055Z",
      "provider": "osv",
      "references": [
        "https://everestforms.net/changelog/",
        "https://wordpress.org/plugins/everest-forms/",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/9e3a118f-4321-4579-a986-05ce077dc6b9?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/5xxx/CVE-2025-5927.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-5927"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-36"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.9.4"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/5xxx/CVE-2025-5927.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-5927",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 503969,
  "published_at": "2025-06-25T09:21:40.614+00:00"
}