Skip to content
Heist/ feed
Back to feed
HighFix available

vllm — security advisory

Type: advisorySources: OSVAdvisory ID: PYSEC-2026-4324

vLLM is an inference and serving engine for large language models. In versions from 0.22.1 through 0.28.0, the operator-supplied model revision pin (--revision / --code-revision) is not propagated to several Hugging Face artifact loads for the FunAudioChat and Tarsier2 architectures: the WhisperFeatureExtractor and speech_tokenizer PreTrainedTokenizerFast loads in vllm/model_executor/models/funaudiochat.py and the Qwen2VLConfig.from_pretrained call used by Tarsier2ProcessingInfo in vllm/model_executor/models/qwen2_vl.py. As a result, deployments pinned to a reviewed revision still resolve these behavior-affecting processor, tokenizer, and config artifacts from the repository's default revision, so a later change to the upstream default branch can alter audio preprocessing, speech tokenizer behavior, or Tarsier2 configuration without any change to the operator's configured pin. This is a supply-chain integrity and reproducibility failure for pinned deployments; it is residual to the earlier fix tracked as GHSA-3ww4-5jv9-j5gm / CVE-2026-47155 and does not constitute remote code execution or a trust_remote_code=False bypass. The issue is fixed in version 0.28.0.

Products
vllm
Affected versions
0.22.1, 0.23.0, 0.24.0, 0.25.0, 0.25.1, 0.26.0, 0.27.0, 0.27.1
Fixed versions
0.28.0
CVEs
CVE-2026-100653
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 02:32 UTC · Revision 1

Source evidence

PYSEC-2026-4324

core-osv · Original source

Published 26 Sept 2026, 14:16 UTC

vLLM is an inference and serving engine for large language models. In versions from 0.22.1 through 0.28.0, the operator-supplied model revision pin (--revision / --code-revision) is not propagated to several Hugging Face artifact loads for the FunAudioChat and Tarsier2 architectures: the WhisperFeatureExtractor and speech_tokenizer PreTrainedTokenizerFast loads in vllm/model_executor/models/funaudiochat.py and the Qwen2VLConfig.from_pretrained call used by Tarsier2ProcessingInfo in vllm/model_executor/models/qwen2_vl.py. As a result, deployments pinned to a reviewed revision still resolve these behavior-affecting processor, tokenizer, and config artifacts from the repository's default revision, so a later change to the upstream default branch can alter audio preprocessing, speech tokenizer behavior, or Tarsier2 configuration without any change to the operator's configured pin. This is a supply-chain integrity and reproducibility failure for pinned deployments; it is residual to the earlier fix tracked as GHSA-3ww4-5jv9-j5gm / CVE-2026-47155 and does not constitute remote code execution or a trust_remote_code=False bypass. The issue is fixed in version 0.28.0.

osv:PYSEC-2026-4324

vllm

Fixed versions: 0.28.0

Complete source record
{
  "id": "5413f53675ac28710fc65e2f06e33c4097fc5a140a96e534c4e8649ec8a63993",
  "url": "https://osv.dev/vulnerability/PYSEC-2026-4324",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "PYSEC-2026-4324",
    "summary": "vLLM is an inference and serving engine for large language models. In versions from 0.22.1 through 0.28.0, the operator-supplied model revision pin (--revision / --code-revision) is not propagated to several Hugging Face artifact loads for the FunAudioChat and Tarsier2 architectures: the WhisperFeatureExtractor and speech_tokenizer PreTrainedTokenizerFast loads in vllm/model_executor/models/funaudiochat.py and the Qwen2VLConfig.from_pretrained call used by Tarsier2ProcessingInfo in vllm/model_executor/models/qwen2_vl.py. As a result, deployments pinned to a reviewed revision still resolve these behavior-affecting processor, tokenizer, and config artifacts from the repository's default revision, so a later change to the upstream default branch can alter audio preprocessing, speech tokenizer behavior, or Tarsier2 configuration without any change to the operator's configured pin. This is a supply-chain integrity and reproducibility failure for pinned deployments; it is residual to the earlier fix tracked as GHSA-3ww4-5jv9-j5gm / CVE-2026-47155 and does not constitute remote code execution or a trust_remote_code=False bypass. The issue is fixed in version 0.28.0.",
    "evidence": "osv:PYSEC-2026-4324",
    "products": [
      {
        "name": {
          "value": "vllm",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.28.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "0.22.1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "0.23.0",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "0.24.0",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "0.25.0",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "0.25.1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "0.26.0",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "0.27.0",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "0.27.1",
            "evidence": "/affected/0/versions"
          }
        ]
      }
    ],
    "severity": "high",
    "structured": {
      "id": "PYSEC-2026-4324",
      "aliases": [
        "CVE-2026-100653",
        "GHSA-hhv2-872h-628q",
        "PYSEC-2026-4324"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0.22.1"
                },
                {
                  "fixed": "0.28.0"
                }
              ]
            }
          ],
          "package": {
            "name": "vllm",
            "purl": "pkg:pypi/vllm",
            "ecosystem": "PyPI"
          },
          "versions": [
            "0.22.1",
            "0.23.0",
            "0.24.0",
            "0.25.0",
            "0.25.1",
            "0.26.0",
            "0.27.0",
            "0.27.1"
          ],
          "database_specific": {
            "source": "https://github.com/pypa/advisory-database/blob/main/vulns/vllm/PYSEC-2026-4324.yaml"
          },
          "ecosystem_specific": {}
        }
      ],
      "modified": "2026-10-23T19:00:39.873437407Z",
      "provider": "osv",
      "references": [
        "https://www.vulncheck.com/advisories/vllm-0.22.1-before-0.28.0-incomplete-artifact-pin-propagation",
        "https://github.com/vllm-project/vllm/commit/d26a28ab033697f55a1414b5b0435de7cd6045b6",
        "https://github.com/vllm-project/vllm/security/advisories/GHSA-hhv2-872h-628q"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-100653",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 424610,
  "published_at": "2026-09-26T14:16:47.953+00:00"
}