Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage
Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-24009
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 16:45 UTC · Revision 1
Source evidence
Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage
core-osv · Original sourcePublished 22 Jan 2026, 15:04 UTC
Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.
osv:CVE-2026-24009
Complete source record
{
"id": "b0420a59708e3e016fb59d815703c7e08662a3f20a21849e4739975973ef3c99",
"url": "https://osv.dev/vulnerability/CVE-2026-24009",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage",
"summary": "Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.",
"evidence": "osv:CVE-2026-24009",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-24009",
"aliases": [
"CVE-2026-24009",
"GHSA-vqxf-v2gg-x3hc",
"PYSEC-2026-1313"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/docling-project/docling-core",
"type": "GIT",
"events": [
{
"introduced": "b2c974696cf7b15037932b6d62724404823712f9"
},
{
"fixed": "c52605dded70787e647a100a30c85a05c4e989a9"
},
{
"fixed": "3e8d628eeeae50f0f8f239c8c7fea773d065d80c"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:docling:docling-core:*:*:*:*:*:python:*:*",
"range": [
{
"introduced": "2.21.0"
},
{
"fixed": "2.48.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "3e8d628eeeae50f0f8f239c8c7fea773d065d80c"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "c52605dded70787e647a100a30c85a05c4e989a9"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v2.48.4"
}
]
}
}
],
"versions": [
"v2.48.3",
"v2.48.2",
"v2.48.1",
"v2.48.0",
"v2.47.0",
"v2.46.0",
"v2.45.0",
"v2.44.2",
"v2.44.1",
"v2.44.0",
"v2.43.1",
"v2.43.0",
"v2.42.0",
"v2.41.0",
"v2.40.0",
"v2.39.0",
"v2.38.2",
"v2.38.1",
"v2.38.0",
"v2.37.0",
"v2.36.0",
"v2.35.0",
"v2.34.2",
"v2.34.1",
"v2.34.0",
"v2.33.1",
"v2.33.0",
"v2.32.0",
"v2.31.2",
"v2.31.1",
"v2.31.0",
"v2.30.1",
"v2.30.0",
"v2.29.0",
"v2.28.1",
"v2.28.0",
"v2.27.0",
"v2.26.4",
"v2.26.3",
"v2.26.2",
"v2.26.1",
"v2.26.0",
"v2.25.0",
"v2.24.1",
"v2.24.0",
"v2.23.3",
"v2.23.2",
"v2.23.1",
"v2.23.0",
"v2.22.0",
"v2.21.2",
"v2.21.1",
"v2.21.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-24009.json"
}
}
],
"modified": "2026-10-28T02:30:30.800480034Z",
"provider": "osv",
"references": [
"https://github.com/docling-project/docling-core/releases/tag/v2.48.4",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/24xxx/CVE-2026-24009.json",
"https://github.com/advisories/GHSA-8q59-q68h-6hv4",
"https://github.com/docling-project/docling-core/security/advisories/GHSA-vqxf-v2gg-x3hc",
"https://nvd.nist.gov/vuln/detail/CVE-2026-24009",
"https://github.com/docling-project/docling-core/issues/482",
"https://github.com/docling-project/docling-core/commit/3e8d628eeeae50f0f8f239c8c7fea773d065d80c"
],
"provider_metadata": {
"cwe_ids": [
"CWE-502"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/24xxx/CVE-2026-24009.json"
}
},
"related_cves": [
{
"value": "CVE-2026-24009",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497537,
"published_at": "2026-01-22T15:04:52.745+00:00"
}