Skip to content
Heist/ feed
Back to feed
UnratedFix available

Drupal core - Moderately critical - Gadget Chain - SA-CORE-2026-002

Type: patchSources: Drupal security

Drupal core has a gadget chain that may enable remote code execution or SQL injection if another vulnerability allows unsafe data to reach unserialize(). Install the listed Drupal core updates; the issue is not directly exploitable.

Products
Drupal core
Affected versions
>= 8.0.0 < 10.5.9 || >= 10.6.0 < 10.6.7 || >= 11.0.0 < 11.2.11 || >= 11.3.0 < 11.3.7
Fixed versions
Drupal 10.5.9, Drupal 10.6.7, Drupal 11.2.11, Drupal 11.3.7
CVEs
CVE-2026-6366
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 12:34 UTC · Revision 1

Source evidence

Drupal core - Moderately critical - Gadget Chain - SA-CORE-2026-002

official-drupal-security · Original source

Published 15 Apr 2026, 19:25 UTC

Drupal core has a gadget chain that may enable remote code execution or SQL injection if another vulnerability allows unsafe data to reach unserialize(). Install the listed Drupal core updates; the issue is not directly exploitable.

Drupal core contains a chain of methods that could be exploitable when an insecure deserialization vulnerability exists on the site.

Drupal core

Fixed versions: Drupal 10.5.9, Drupal 10.6.7, Drupal 11.2.11, Drupal 11.3.7

Prerequisites: a separate vulnerability must be present to allow an attacker to pass unsafe input to unserialize()

Complete source record
{
  "id": "fa07449fa27afadc09464a05dbcd588145ce24ba73aeacbe1bd3478d865ecb66",
  "url": "https://www.drupal.org/sa-core-2026-002",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Moderately critical - Gadget Chain - SA-CORE-2026-002",
    "summary": "Drupal core has a gadget chain that may enable remote code execution or SQL injection if another vulnerability allows unsafe data to reach unserialize(). Install the listed Drupal core updates; the issue is not directly exploitable.",
    "evidence": "Drupal core contains a chain of methods that could be exploitable when an insecure deserialization vulnerability exists on the site.",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [
          {
            "value": "a separate vulnerability must be present to allow an attacker to pass unsafe input to unserialize()",
            "evidence": "This issue is mitigated by the fact that in order for it to be exploitable, a separate vulnerability must be present to allow an attacker to pass unsafe input to unserialize()."
          }
        ],
        "fixed_versions": [
          {
            "value": "Drupal 10.5.9",
            "evidence": "If you use Drupal 10.5.x, update to Drupal 10.5.9."
          },
          {
            "value": "Drupal 10.6.7",
            "evidence": "If you use Drupal 10.6.x, update to Drupal 10.6.7."
          },
          {
            "value": "Drupal 11.2.11",
            "evidence": "If you use Drupal 11.2.x, update to Drupal 11.2.11."
          },
          {
            "value": "Drupal 11.3.7",
            "evidence": "If you use Drupal 11.3.x, update to Drupal 11.3.7."
          }
        ],
        "affected_versions": [
          {
            "value": ">= 8.0.0 < 10.5.9 || >= 10.6.0 < 10.6.7 || >= 11.0.0 < 11.2.11 || >= 11.3.0 < 11.3.7",
            "evidence": "Affected versions: >= 8.0.0 < 10.5.9 || >= 10.6.0 < 10.6.7 || >= 11.0.0 < 11.2.11 || >= 11.3.0 < 11.3.7"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2026-6366",
        "evidence": "CVE IDs: CVE-2026-6366"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-drupal-security",
  "document_id": 23466,
  "published_at": "2026-04-15T19:25:23+00:00"
}