High
WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability
Type: advisorySources: OSV
Missing Authorization vulnerability in Post SMTP Post SMTP Mailer/Email Log.This issue affects Post SMTP Mailer/Email Log: from n/a through 2.8.6.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-52233
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 04:55 UTC · Revision 1
Source evidence
WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability
core-osv · Original sourcePublished 11 Jun 2024, 16:05 UTC
Missing Authorization vulnerability in Post SMTP Post SMTP Mailer/Email Log.This issue affects Post SMTP Mailer/Email Log: from n/a through 2.8.6.
osv:CVE-2023-52233
Complete source record
{
"id": "72a1082b7a2603c602d540d14724bf5c9442447f6ca1d591b84821408cff4f62",
"url": "https://osv.dev/vulnerability/CVE-2023-52233",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability",
"summary": "Missing Authorization vulnerability in Post SMTP Post SMTP Mailer/Email Log.This issue affects Post SMTP Mailer/Email Log: from n/a through 2.8.6.",
"evidence": "osv:CVE-2023-52233",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-52233",
"aliases": [
"CVE-2023-52233"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wpexpertsio/post-smtp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "437956ad80f774c66350ad620f75262cd50ebc34"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.8.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.5.9-beta.1",
"2.8.5",
"2.8.4",
"2.7.0",
"2.8.3",
"2.7.2",
"2.6.0",
"2.5.9.4",
"2.5.9.3",
"2.5.8",
"2.5.7",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.5-rc.3",
"2.5-rc.2",
"2.5-rc.1",
"2.5-beta.1",
"2.4.3",
"2.4.2-beta.2",
"2.4.2",
"2.4.1",
"2.4",
"2.4-beta.1",
"2.3.1",
"2.3",
"2.2.1",
"2.2",
"2.2-beta.2",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.4",
"2.1.4-rc.2",
"2.1.4-rc.1",
"2.1.4-beta.1",
"2.1.2",
"2.1.2-rc.2",
"2.1.2-rc.1",
"2.1.2-beta-1",
"2.1.1.1",
"2.1.1",
"2.1",
"2.1-beta.1",
"2.0.27",
"2.0.26",
"2.0.25-beta.1",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"v1.9.8",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v.1.9.2",
"v.1.9.1",
"v.1.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-52233.json"
}
}
],
"modified": "2026-10-28T02:30:25.893248939Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/52xxx/CVE-2023-52233.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-52233",
"https://patchstack.com/database/vulnerability/post-smtp/wordpress-post-smtp-mailer-plugin-2-8-6-broken-access-control-on-api-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "2.8.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/52xxx/CVE-2023-52233.json"
}
},
"related_cves": [
{
"value": "CVE-2023-52233",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492591,
"published_at": "2024-06-11T16:05:38.545+00:00"
}