SendPress Newsletters <= 1.22.3.31 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
The SendPress Newsletters plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 1.22.3.31 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-5660
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 18:05 UTC · Revision 1
Source evidence
SendPress Newsletters <= 1.22.3.31 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
core-osv · Original sourcePublished 7 Nov 2023, 11:31 UTC
The SendPress Newsletters plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 1.22.3.31 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
osv:CVE-2023-5660
Complete source record
{
"id": "77e3d2bba9e3b95a93fabd6126533f223d9556b74ab97fd9038bcefcdf4e6c0c",
"url": "https://osv.dev/vulnerability/CVE-2023-5660",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "SendPress Newsletters <= 1.22.3.31 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode",
"summary": "The SendPress Newsletters plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 1.22.3.31 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"evidence": "osv:CVE-2023-5660",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-5660",
"aliases": [
"CVE-2023-5660"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/brewlabs/sendpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6fcc4512569b5a8201cc9c15f1482d2f6873b81b"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:pressified:sendpress:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.23.11.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.22.3.31",
"1.22.3.14",
"1.22.2.18",
"1.22.1.20",
"1.21.4.5",
"1.20.10.6",
"1.20.8.21",
"1.20.7.13",
"1.20.7.10",
"1.20.6.08",
"1.20.4.13",
"1.20.3.19",
"1.20.3.17",
"1.20.2.20",
"1.20.1.7",
"1.10.9.23",
"1.10.8.14",
"1.10.6.18",
"1.10.6.11",
"1.10.5.19",
"1.10.4.10",
"1.10.3.28",
"1.9.11.26",
"1.9.11.16",
"1.9.11.15",
"1.9.10.15",
"1.9.10.5",
"1.9.7.17",
"1.9.7.13",
"1.9.6.26",
"1.9.6.20",
"1.9.6.19.1",
"1.9.5.10",
"1.9.3.29.1",
"1.9.3.29",
"1.9.3.28",
"1.9.3.21",
"1.9.3.19",
"1.9.3.5",
"1.9.2.26",
"1.9.2.23.1",
"1.9.2.23",
"1.9.2.22",
"1.8.12.18",
"1.8.11.25",
"1.8.11.5",
"1.8.11.2",
"1.8.10.26",
"1.8.9.27",
"1.8.8.14",
"1.8.7.10.1",
"1.8.7.10",
"1.8.6.16",
"1.8.5.31",
"1.8.5.24",
"1.7.12.15",
"1.7.12.7",
"1.7.12.1",
"1.7.11.22",
"1.7.11.14",
"1.7.10.13",
"1.7.10.12",
"1.7.9.19",
"1.7.5.24",
"1.7.5.2",
"1.7.4.27",
"1.7.4.20",
"1.7.4.13",
"1.7.3.19",
"1.7",
"1.6.2.22",
"1.6.1.20",
"1.5.12.20",
"1.5.12.13",
"1.5.11.9",
"1.5",
"1.2.10.12",
"1.2.10.10",
"1.2.10.6.1",
"1.2.10.6",
"1.2.9.13",
"1.2.9.9",
"1.2.8.28",
"1.2.8.16",
"1.2.8.13",
"1.2.8.10",
"1.2.8.3",
"1.2.7.29",
"1.2.7.27",
"1.2.7.26",
"1.2.1",
"1.2",
"1.1.7.21",
"1.1.7.14",
"1.1.5.4",
"1.1.4.22",
"1.1.4.21",
"1.1.4.3",
"1.1.4.2",
"1.1.3.10.1",
"1.1.3.10",
"1.1.2.24",
"1.1.2.22",
"1.1.2.11",
"1.0.9",
"1.0.3",
"1.0.2",
"1.0",
"0.9.9.9.9",
"0.9.9.9.8",
"0.9.9.9.7",
"0.9.9.9.6",
"0.9.9.9.5",
"0.9.9.9.4",
"0.9.9.9.3",
"0.9.9.9.2",
"0.9.9.9.1",
"0.9.9.9",
"0.9.9.8",
"0.9.9.7",
"0.9.9.6",
"0.9.9.5",
"0.9.9.4",
"0.9.9.3",
"0.9.9.2",
"0.9.9.1",
"0.9.9",
"0.9.8.7",
"0.9.8.6",
"0.9.8.5",
"0.9.8.4",
"0.9.8.3",
"0.9.8.2",
"0.9.8.1",
"0.9.8",
"0.9.7.3",
"0.9.7.2",
"0.9.7.1",
"0.9.6.4",
"0.9.6.3",
"0.9.6.2",
"0.9.6.1",
"0.9.6",
"0.9.5.2",
"0.9.5.1",
"0.9.5",
"0.9.4.7",
"0.9.4.6",
"0.9.4.5",
"0.9.4.3",
"0.9.4.2",
"0.9.4",
"0.9.3.4",
"0.9.3.3",
"0.9.3.2",
"0.9.3.1",
"0.9.3",
"0.9.2.1",
"0.9.2",
"0.9.2-Beta",
"0.8.8.1",
"0.8.8"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-5660.json"
}
}
],
"modified": "2026-10-28T02:30:51.372116482Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/browser/sendpress/tags/1.22.3.31/classes/sc/class-sendpress-sc-unsubscribe-form.php#L57",
"https://plugins.trac.wordpress.org/changeset/2990357/sendpress#file5",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/cbce42a0-29a7-40df-973c-1fe7338f6c94?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/5xxx/CVE-2023-5660.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-5660"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "1.22.3.31"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/5xxx/CVE-2023-5660.json"
}
},
"related_cves": [
{
"value": "CVE-2023-5660",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 520047,
"published_at": "2023-11-07T11:31:09.31+00:00"
}