Skip to content
Heist/ feed
Back to feed
High

Slimstat Analytics <= 5.2.6 - Unauthenticated Stored Cross-Site Scripting

Type: advisorySources: OSV

The SlimStat Analytics plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the resource parameter in all versions up to, and including, 5.2.6 due to insufficient input sanitization and output escaping when logging visitor requests. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-9548
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 17:10 UTC · Revision 1

Source evidence

Slimstat Analytics <= 5.2.6 - Unauthenticated Stored Cross-Site Scripting

core-osv · Original source

Published 14 Oct 2024, 23:29 UTC

The SlimStat Analytics plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the resource parameter in all versions up to, and including, 5.2.6 due to insufficient input sanitization and output escaping when logging visitor requests. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

osv:CVE-2024-9548
Complete source record
{
  "id": "7362a769f5f9d145cb77b5cdcac8d7baea4c996a913254e242d67925cef386a6",
  "url": "https://osv.dev/vulnerability/CVE-2024-9548",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Slimstat Analytics <= 5.2.6 - Unauthenticated Stored Cross-Site Scripting",
    "summary": "The SlimStat Analytics plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the resource parameter in all versions up to, and including, 5.2.6 due to insufficient input sanitization and output escaping when logging visitor requests. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
    "evidence": "osv:CVE-2024-9548",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-9548",
      "aliases": [
        "CVE-2024-9548"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wp-slimstat/wp-slimstat",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a0f72bf4e3af761d1bb101869de00b7711e57c9c"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wp-slimstat:slimstat_analytics:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.2.7"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v5.2.6",
            "v5.2.5",
            "v5.2.4",
            "v5.2.3",
            "v5.2.2",
            "v5.2.1",
            "v5.2",
            "v5.1.5",
            "v5.1.4",
            "v5.1.3",
            "v5.1.2",
            "v5.1.1",
            "v5.1",
            "v5.0.10.2",
            "v5.0.10.1",
            "v5.0.10",
            "v5.0.9",
            "v5.0.8",
            "v5.0.7",
            "v5.0.6",
            "v5.0.5.1",
            "v5.0.5",
            "v5.0.4",
            "v5.0.3",
            "v5.0.2",
            "v5.0.1",
            "v5.0",
            "v4.9.4",
            "v4.9.3.3",
            "v4.9.3.2",
            "v4.9.3.1",
            "v4.9.3",
            "v4.9.2",
            "4.9.0.1",
            "4.9",
            "4.8.3",
            "4.8.2",
            "4.8.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-9548.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:30.510481848Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/wp-slimstat/tags/5.2.6",
        "https://plugins.trac.wordpress.org/browser/wp-slimstat/tags/5.2.6/admin/view/right-now.php#L196",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/fa91912d-5794-4c96-8a13-bd54ce0f1deb?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9548.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-9548"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "5.2.6"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9548.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-9548",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 497710,
  "published_at": "2024-10-14T23:29:56.661+00:00"
}