Komga Vulnerable to Arbitrary Code Execution via Crafted EPUB File
Komga is a media server for comics, mangas, BDs, magazines and eBooks. A Cross-Site Scripting (XSS) vulnerability has been discovered in versions 1.8.0 through 1.21.3 when serving EPUB resources, either directly from the API, or when reading using the epub reader. The vulnerability lets an attacker perform actions on the victim's behalf. When targeting an admin user, this can be combined with controlling a server-side command to achieve arbitrary code execution. For this vulnerability to be exploited, a malicious EPUB file has to be present in a Komga library, and subsequently accessed in the Epub reader by an admin user. Version 1.22.0 contains a patch for the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-52880
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 13:48 UTC · Revision 1
Source evidence
Komga Vulnerable to Arbitrary Code Execution via Crafted EPUB File
core-osv · Original sourcePublished 24 Jun 2025, 19:56 UTC
Komga is a media server for comics, mangas, BDs, magazines and eBooks. A Cross-Site Scripting (XSS) vulnerability has been discovered in versions 1.8.0 through 1.21.3 when serving EPUB resources, either directly from the API, or when reading using the epub reader. The vulnerability lets an attacker perform actions on the victim's behalf. When targeting an admin user, this can be combined with controlling a server-side command to achieve arbitrary code execution. For this vulnerability to be exploited, a malicious EPUB file has to be present in a Komga library, and subsequently accessed in the Epub reader by an admin user. Version 1.22.0 contains a patch for the issue.
osv:CVE-2025-52880
Complete source record
{
"id": "fcb2402823149c9326d50bf42eb4d67d38c6f5204d6c42879bd2810d31dc5304",
"url": "https://osv.dev/vulnerability/CVE-2025-52880",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Komga Vulnerable to Arbitrary Code Execution via Crafted EPUB File",
"summary": "Komga is a media server for comics, mangas, BDs, magazines and eBooks. A Cross-Site Scripting (XSS) vulnerability has been discovered in versions 1.8.0 through 1.21.3 when serving EPUB resources, either directly from the API, or when reading using the epub reader. The vulnerability lets an attacker perform actions on the victim's behalf. When targeting an admin user, this can be combined with controlling a server-side command to achieve arbitrary code execution. For this vulnerability to be exploited, a malicious EPUB file has to be present in a Komga library, and subsequently accessed in the Epub reader by an admin user. Version 1.22.0 contains a patch for the issue.",
"evidence": "osv:CVE-2025-52880",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-52880",
"aliases": [
"CVE-2025-52880",
"GHSA-m7mm-6jxp-2m4x"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gotson/komga",
"type": "GIT",
"events": [
{
"introduced": "6e5e7a942ad267d3855e7b13d7b282fbf6f063e3"
},
{
"fixed": "76feaa13c84dd2d9091a06a016477619dea4abd7"
},
{
"fixed": "5f9cc449b7846ed2066752c72c9ce7b20c3a85a7"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.22.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "5f9cc449b7846ed2066752c72c9ce7b20c3a85a7"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.21.3",
"1.21.2",
"1.21.1",
"1.21.0",
"1.20.0",
"1.19.1",
"1.19.0",
"1.18.0",
"1.17.0",
"1.16.0",
"1.15.1",
"1.15.0",
"1.14.1",
"1.14.0",
"1.13.0",
"1.12.1",
"1.12.0",
"1.11.3",
"1.11.2",
"1.11.1",
"1.11.0",
"1.10.4",
"1.10.3",
"1.10.2",
"1.10.1",
"1.10.0",
"1.9.2",
"1.9.1",
"1.9.0",
"1.8.4",
"1.8.3",
"1.8.2",
"1.8.1",
"1.8.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-52880.json"
}
}
],
"modified": "2026-10-28T02:30:36.085669532Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/52xxx/CVE-2025-52880.json",
"https://github.com/gotson/komga/security/advisories/GHSA-m7mm-6jxp-2m4x",
"https://nvd.nist.gov/vuln/detail/CVE-2025-52880",
"https://github.com/gotson/komga/commit/5f9cc449b7846ed2066752c72c9ce7b20c3a85a7"
],
"provider_metadata": {
"cwe_ids": [
"CWE-799"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/52xxx/CVE-2025-52880.json"
}
},
"related_cves": [
{
"value": "CVE-2025-52880",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503300,
"published_at": "2025-06-24T19:56:12.692+00:00"
}