Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-4315

A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-4315
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:21 UTC · Revision 1

Source evidence

CVE-2021-4315

core-osv · Original source

Published 28 Jan 2023, 23:15 UTC

A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.

osv:CVE-2021-4315
Complete source record
{
  "id": "ae65485b2752835343eafe38c2a068577ad84ad9b349abb29665926a7397765d",
  "url": "https://osv.dev/vulnerability/CVE-2021-4315",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-4315",
    "summary": "A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.",
    "evidence": "osv:CVE-2021-4315",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2021-4315",
      "aliases": [
        "CVE-2021-4315",
        "GHSA-9mq4-9556-6qxq",
        "PYSEC-2023-43"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/nyuccl/psiturk",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2a2de2be90e701b99a30822ad2e47c2ef9a6be01"
                },
                {
                  "fixed": "47787e15cecd66f2aa87687bf852ae0194a4335f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:psiturk:psiturk:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "3.2.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "47787e15cecd66f2aa87687bf852ae0194a4335f"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "2a2de2be90e701b99a30822ad2e47c2ef9a6be01"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v3.2.1"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v3.2.0",
            "v3.1.0",
            "v3.0.6",
            "v2.3.12-travis-1",
            "v3.0.5",
            "v3.0.4",
            "v3.0.3",
            "v3.0.2",
            "v3.0.1",
            "v3.0.0",
            "2.3.2",
            "2.3.1-alpha",
            "2.3.1",
            "2.3.0",
            "2.2.3",
            "2.2.2",
            "2.2.1",
            "2.2.0",
            "2.1.7",
            "2.1.6",
            "2.1.5",
            "2.1.4",
            "2.1.3",
            "2.1.2",
            "2.1.1",
            "2.1.0",
            "2.0.1",
            "2.0.0",
            "v1.0.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-4315.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:07.482444875Z",
      "provider": "osv",
      "references": [
        "https://github.com/NYUCCL/psiTurk/releases/tag/v3.2.1",
        "https://github.com/NYUCCL/psiTurk/pull/517",
        "https://vuldb.com/?ctiid.219676",
        "https://vuldb.com/?id.219676",
        "https://github.com/NYUCCL/psiTurk/commit/47787e15cecd66f2aa87687bf852ae0194a4335f"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-4315",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 384879,
  "published_at": "2023-01-28T23:15:08.687+00:00"
}