ruby-nokogiri — security advisory
Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, XInclude substitution performed by Nokogiri::XML::Node#do_xinclude replaced each in place, freeing the include node along with its children (such as and its descendants) and any namespaces declared on them. If an application had already exposed one of those nodes or namespaces to Ruby, the corresponding Ruby object was left pointing at freed memory. Using the object could result in invalid reads or writes to memory. This vulnerability is fixed in 1.19.4.
- Products
- ruby-nokogiri
- Affected versions
- 1.13.10+dfsg-2, 1.14.2+dfsg-1, 1.14.3+dfsg-1, 1.14.3+dfsg-2, 1.15.4+dfsg-1, 1.16.0+dfsg-1, 1.16.0+dfsg-2, 1.16.2+dfsg-1, 1.16.4+dfsg-1, 1.17.2+dfsg-1~exp1, 1.18.10+dfsg-1, 1.18.10+dfsg-2, 1.18.10+dfsg-3, 1.18.2+dfsg-1, 1.19.1+dfsg-1, 1.19.3+dfsg-1, 1.19.4+dfsg-1
- Fixed versions
- 1.19.4+dfsg-1
- CVEs
- CVE-2026-57438
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 12:18 UTC · Revision 2
Source evidence
Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, XInclude substitution performed by Nokogiri::XML::Node#do_xinclude replaced each in place, freeing the include node along with its children (such as and its descendants) and any namespaces declared on them. If an application had already exposed one of those nodes or namespaces to Ruby, the corresponding Ruby object was left pointing at freed memory. Using the object could result in invalid reads or writes to memory. This vulnerability is fixed in 1.19.4.
osv:DEBIAN-CVE-2026-57438
ruby-nokogiri
Fixed versions: Not specified
ruby-nokogiri
Fixed versions: Not specified
ruby-nokogiri
Fixed versions: 1.19.4+dfsg-1
Complete source record
{
"id": "da7cabfe89991e261586c204a589ae752905f5b98c13fc7bfcbd9a8db20d41e9",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-57438",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-57438",
"summary": "Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, XInclude substitution performed by Nokogiri::XML::Node#do_xinclude replaced each in place, freeing the include node along with its children (such as and its descendants) and any namespaces declared on them. If an application had already exposed one of those nodes or namespaces to Ruby, the corresponding Ruby object was left pointing at freed memory. Using the object could result in invalid reads or writes to memory. This vulnerability is fixed in 1.19.4.",
"evidence": "osv:DEBIAN-CVE-2026-57438",
"products": [
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.13.10+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.14.2+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.14.3+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.14.3+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.15.4+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.16.0+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.16.0+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.16.2+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.16.4+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.17.2+dfsg-1~exp1",
"evidence": "/affected/0/versions"
},
{
"value": "1.18.10+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.18.10+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.18.10+dfsg-3",
"evidence": "/affected/0/versions"
},
{
"value": "1.18.2+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.19.1+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.19.3+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.19.4+dfsg-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.18.10+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.18.10+dfsg-2",
"evidence": "/affected/1/versions"
},
{
"value": "1.18.10+dfsg-3",
"evidence": "/affected/1/versions"
},
{
"value": "1.18.2+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.19.1+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.19.3+dfsg-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.19.4+dfsg-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "ruby-nokogiri",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.19.4+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.18.10+dfsg-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.18.10+dfsg-2",
"evidence": "/affected/2/versions"
},
{
"value": "1.18.10+dfsg-3",
"evidence": "/affected/2/versions"
},
{
"value": "1.18.2+dfsg-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.19.1+dfsg-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.19.3+dfsg-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2026-57438",
"aliases": [
"DEBIAN-CVE-2026-57438"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.13.10+dfsg-2",
"1.14.2+dfsg-1",
"1.14.3+dfsg-1",
"1.14.3+dfsg-2",
"1.15.4+dfsg-1",
"1.16.0+dfsg-1",
"1.16.0+dfsg-2",
"1.16.2+dfsg-1",
"1.16.4+dfsg-1",
"1.17.2+dfsg-1~exp1",
"1.18.10+dfsg-1",
"1.18.10+dfsg-2",
"1.18.10+dfsg-3",
"1.18.2+dfsg-1",
"1.19.1+dfsg-1",
"1.19.3+dfsg-1",
"1.19.4+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-57438.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.18.10+dfsg-1",
"1.18.10+dfsg-2",
"1.18.10+dfsg-3",
"1.18.2+dfsg-1",
"1.19.1+dfsg-1",
"1.19.3+dfsg-1",
"1.19.4+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-57438.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.19.4+dfsg-1"
}
]
}
],
"package": {
"name": "ruby-nokogiri",
"purl": "pkg:deb/debian/ruby-nokogiri?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.18.10+dfsg-1",
"1.18.10+dfsg-2",
"1.18.10+dfsg-3",
"1.18.2+dfsg-1",
"1.19.1+dfsg-1",
"1.19.3+dfsg-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-57438.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T11:47:31.067270321Z",
"provider": "osv",
"upstream": [
"CVE-2026-57438"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-57438"
]
},
"related_cves": [
{
"value": "CVE-2026-57438",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 450813,
"published_at": "2026-06-25T16:16:42.13+00:00"
}