Skip to content
Heist/ feed
Back to feed
HighFix available

xrdp — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-23613

xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.

Products
xrdp
Affected versions
Not specified
Fixed versions
0.9.17-2.1
CVEs
CVE-2022-23613
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:43 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-23613

core-osv · Original source

Published 7 Feb 2022, 22:15 UTC

xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.

osv:DEBIAN-CVE-2022-23613

xrdp

Fixed versions: 0.9.17-2.1

xrdp

Fixed versions: 0.9.17-2.1

xrdp

Fixed versions: 0.9.17-2.1

Complete source record
{
  "id": "b310e8e278504bb77ac3a8df34ad68688f5a6149df26d73e3a9443142135b014",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23613",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-23613",
    "summary": "xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.",
    "evidence": "osv:DEBIAN-CVE-2022-23613",
    "products": [
      {
        "name": {
          "value": "xrdp",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.9.17-2.1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "xrdp",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.9.17-2.1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "xrdp",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.9.17-2.1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2022-23613",
      "aliases": [
        "DEBIAN-CVE-2022-23613"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.9.17-2.1"
                }
              ]
            }
          ],
          "package": {
            "name": "xrdp",
            "purl": "pkg:deb/debian/xrdp?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23613.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.9.17-2.1"
                }
              ]
            }
          ],
          "package": {
            "name": "xrdp",
            "purl": "pkg:deb/debian/xrdp?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23613.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.9.17-2.1"
                }
              ]
            }
          ],
          "package": {
            "name": "xrdp",
            "purl": "pkg:deb/debian/xrdp?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23613.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:01:42.872969176Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-23613"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-23613"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-23613",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323107,
  "published_at": "2022-02-07T22:15:08.65+00:00"
}