UnratedFix available
pillow — security advisory
Python Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibly JpegImagePlugin.py.
- Products
- pillow
- Affected versions
- Not specified
- Fixed versions
- 2.4.0-1
- CVEs
- CVE-2014-3007
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:49 UTC · Revision 1
Source evidence
Python Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibly JpegImagePlugin.py.
osv:DEBIAN-CVE-2014-3007
pillow
Fixed versions: 2.4.0-1
pillow
Fixed versions: 2.4.0-1
pillow
Fixed versions: 2.4.0-1
Complete source record
{
"id": "aa74ae3fd8ed3dba6fdfdd2ae9cf02dc884ce41f79258fbfb08bd02aae7eebeb",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-3007",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-3007",
"summary": "Python Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibly JpegImagePlugin.py.",
"evidence": "osv:DEBIAN-CVE-2014-3007",
"products": [
{
"name": {
"value": "pillow",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.0-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pillow",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pillow",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-3007",
"aliases": [
"DEBIAN-CVE-2014-3007"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.0-1"
}
]
}
],
"package": {
"name": "pillow",
"purl": "pkg:deb/debian/pillow?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3007.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.0-1"
}
]
}
],
"package": {
"name": "pillow",
"purl": "pkg:deb/debian/pillow?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3007.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.0-1"
}
]
}
],
"package": {
"name": "pillow",
"purl": "pkg:deb/debian/pillow?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3007.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:39.816112860Z",
"provider": "osv",
"upstream": [
"CVE-2014-3007"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-3007"
]
},
"related_cves": [
{
"value": "CVE-2014-3007",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 414615,
"published_at": "2014-04-27T20:55:23.697+00:00"
}