MediumFix available
WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query
Type: advisorySources: OSV
WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.
- Products
- wordpress
- Affected versions
- Not specified
- Fixed versions
- 6.8.6, 6.9.5, 7.0.2
- CVEs
- CVE-2026-60137
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:02 UTC · Revision 1
Source evidence
WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query
core-osv · Original sourcePublished 27 Jul 2026, 05:55 UTC
WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.
osv:BIT-wordpress-2026-60137
wordpress
Fixed versions: 6.8.6, 6.9.5, 7.0.2
Complete source record
{
"id": "5fe05259195f85cecc0f4c2c4727c62c0d872e792bef8dbd11c64686ae6e25ed",
"url": "https://osv.dev/vulnerability/BIT-wordpress-2026-60137",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query",
"summary": "WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.",
"evidence": "osv:BIT-wordpress-2026-60137",
"products": [
{
"name": {
"value": "wordpress",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.8.6",
"evidence": "/affected/0/ranges"
},
{
"value": "6.9.5",
"evidence": "/affected/0/ranges"
},
{
"value": "7.0.2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "BIT-wordpress-2026-60137",
"aliases": [
"BIT-wordpress-2026-60137",
"BIT-wordpress-multisite-2026-60137",
"CVE-2026-60137"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "6.8.0"
},
{
"fixed": "6.8.6"
},
{
"introduced": "6.9.0"
},
{
"fixed": "6.9.5"
},
{
"introduced": "7.0.0"
},
{
"fixed": "7.0.2"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:bitnami/wordpress",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/wordpress/BIT-wordpress-2026-60137.json"
}
}
],
"modified": "2026-10-08T09:15:02.722180481Z",
"provider": "osv",
"references": [
"https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-fpp7-x2x2-2mjf",
"https://nvd.nist.gov/vuln/detail/CVE-2026-60137",
"https://wordpress.org/news/2026/07/wordpress-7-0-2-release/",
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-60137"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*"
],
"severity": "Medium"
}
},
"related_cves": [
{
"value": "CVE-2026-60137",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 98829,
"published_at": "2026-07-27T05:55:53.343+00:00"
}