jq — security advisory
jq is a command-line JSON processor. In versions 1.8.1 and below, functions jv_setpath(), jv_getpath(), and delpaths_sorted() in jq's src/jv_aux.c use unbounded recursion whose depth is controlled by the length of a caller-supplied path array, with no depth limit enforced. An attacker can supply a JSON document containing a flat array of ~65,000 integers (~200 KB) that, when used as a path argument by a trusted jq filter, exhausts the C call stack and crashes the process with a segmentation fault (SIGSEGV). This bypass works because the existing MAX_PARSING_DEPTH (10,000) limit only protects the JSON parser, not runtime path operations where arrays can be programmatically constructed to arbitrary lengths. The impact is denial of service (unrecoverable crash) affecting any application or service that processes untrusted JSON input through jq's setpath, getpath, or delpaths builtins. This issue has been addressed in commit fb59f1491058d58bdc3e8dd28f1773d1ac690a1f.
- Products
- jq
- Affected versions
- 1.6-2.1, 1.6-2.1+deb12u1, 1.7.1-6+deb13u1, 1.8.0-1, 1.8.1-1, 1.8.1-2, 1.8.1-3, 1.8.1-4
- Fixed versions
- 1.6-2.1+deb12u2, 1.7.1-6+deb13u2, 1.8.1-5
- CVEs
- CVE-2026-33947
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:51 UTC · Revision 2
Source evidence
jq is a command-line JSON processor. In versions 1.8.1 and below, functions jv_setpath(), jv_getpath(), and delpaths_sorted() in jq's src/jv_aux.c use unbounded recursion whose depth is controlled by the length of a caller-supplied path array, with no depth limit enforced. An attacker can supply a JSON document containing a flat array of ~65,000 integers (~200 KB) that, when used as a path argument by a trusted jq filter, exhausts the C call stack and crashes the process with a segmentation fault (SIGSEGV). This bypass works because the existing MAX_PARSING_DEPTH (10,000) limit only protects the JSON parser, not runtime path operations where arrays can be programmatically constructed to arbitrary lengths. The impact is denial of service (unrecoverable crash) affecting any application or service that processes untrusted JSON input through jq's setpath, getpath, or delpaths builtins. This issue has been addressed in commit fb59f1491058d58bdc3e8dd28f1773d1ac690a1f.
osv:DEBIAN-CVE-2026-33947
jq
Fixed versions: 1.6-2.1+deb12u2
jq
Fixed versions: 1.7.1-6+deb13u2
jq
Fixed versions: 1.8.1-5
Complete source record
{
"id": "a89391ff604aef452ca199fad1f72e9360e278276cc30a7f3485f25323ff6ee7",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-33947",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-33947",
"summary": "jq is a command-line JSON processor. In versions 1.8.1 and below, functions jv_setpath(), jv_getpath(), and delpaths_sorted() in jq's src/jv_aux.c use unbounded recursion whose depth is controlled by the length of a caller-supplied path array, with no depth limit enforced. An attacker can supply a JSON document containing a flat array of ~65,000 integers (~200 KB) that, when used as a path argument by a trusted jq filter, exhausts the C call stack and crashes the process with a segmentation fault (SIGSEGV). This bypass works because the existing MAX_PARSING_DEPTH (10,000) limit only protects the JSON parser, not runtime path operations where arrays can be programmatically constructed to arbitrary lengths. The impact is denial of service (unrecoverable crash) affecting any application or service that processes untrusted JSON input through jq's setpath, getpath, or delpaths builtins. This issue has been addressed in commit fb59f1491058d58bdc3e8dd28f1773d1ac690a1f.",
"evidence": "osv:DEBIAN-CVE-2026-33947",
"products": [
{
"name": {
"value": "jq",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6-2.1+deb12u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.6-2.1",
"evidence": "/affected/0/versions"
},
{
"value": "1.6-2.1+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "jq",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.7.1-6+deb13u2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "1.7.1-6+deb13u1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "jq",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.8.1-5",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.8.0-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-2",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-3",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-4",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2026-33947",
"aliases": [
"DEBIAN-CVE-2026-33947"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6-2.1+deb12u2"
}
]
}
],
"package": {
"name": "jq",
"purl": "pkg:deb/debian/jq?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.6-2.1",
"1.6-2.1+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-33947.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.1-6+deb13u2"
}
]
}
],
"package": {
"name": "jq",
"purl": "pkg:deb/debian/jq?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.7.1-6+deb13u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-33947.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.1-5"
}
]
}
],
"package": {
"name": "jq",
"purl": "pkg:deb/debian/jq?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.8.0-1",
"1.8.1-1",
"1.8.1-2",
"1.8.1-3",
"1.8.1-4"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-33947.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T09:47:42.934417510Z",
"provider": "osv",
"upstream": [
"CVE-2026-33947"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-33947"
]
},
"related_cves": [
{
"value": "CVE-2026-33947",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461363,
"published_at": "2026-04-13T22:16:29.157+00:00"
}