apptainer — security advisory
Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor: and --security=selinux: which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.
- Products
- apptainer
- Affected versions
- 1.4.0-5, 1.4.0-6, 1.4.4-1, 1.4.4-2, 1.4.5-1, 1.4.5-2ubuntu1
- Fixed versions
- Not specified
- CVEs
- CVE-2025-65105
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 01:35 UTC · Revision 1
Source evidence
Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor: and --security=selinux: which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.
osv:UBUNTU-CVE-2025-65105
apptainer
Fixed versions: Not specified
apptainer
Fixed versions: Not specified
apptainer
Fixed versions: Not specified
Complete source record
{
"id": "ef98f0b80a5c1d172a30d9119d6ad7c3516334d115b706dd52db71d09ccb6d72",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2025-65105",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2025-65105",
"summary": "Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor: and --security=selinux: which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.",
"evidence": "osv:UBUNTU-CVE-2025-65105",
"products": [
{
"name": {
"value": "apptainer",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.4.0-5",
"evidence": "/affected/0/versions"
},
{
"value": "1.4.0-6",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "apptainer",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.4.5-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.4.5-2ubuntu1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "apptainer",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.4.0-6",
"evidence": "/affected/2/versions"
},
{
"value": "1.4.4-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.4.4-2",
"evidence": "/affected/2/versions"
},
{
"value": "1.4.5-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2025-65105",
"aliases": [
"UBUNTU-CVE-2025-65105"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apptainer",
"purl": "pkg:deb/ubuntu/apptainer?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"1.4.0-5",
"1.4.0-6"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-65105.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "apptainer",
"binary_version": "1.4.0-6"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apptainer",
"purl": "pkg:deb/ubuntu/apptainer?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"1.4.5-1",
"1.4.5-2ubuntu1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-65105.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "apptainer",
"binary_version": "1.4.5-2ubuntu1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apptainer",
"purl": "pkg:deb/ubuntu/apptainer?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"1.4.0-6",
"1.4.4-1",
"1.4.4-2",
"1.4.5-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-65105.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "apptainer",
"binary_version": "1.4.5-1"
}
]
}
}
],
"modified": "2026-10-17T12:57:11.266047672Z",
"provider": "osv",
"upstream": [
"CVE-2025-65105"
],
"references": [
"https://ubuntu.com/security/CVE-2025-65105",
"https://www.cve.org/CVERecord?id=CVE-2025-65105",
"https://github.com/apptainer/apptainer/security/advisories/GHSA-j3rw-fx6g-q46j",
"https://github.com/apptainer/apptainer/commit/4313b42717e18a4add7dd7503528bc15af905981",
"https://github.com/apptainer/apptainer/commit/82f17900a0c31bc769bf9b4612d271c7068d8bf2",
"https://github.com/apptainer/apptainer/pull/3226",
"https://github.com/opencontainers/runc/security/advisories/GHSA-cgrx-mc8f-2prm",
"https://github.com/sylabs/singularity/security/advisories/GHSA-wwrx-w7c9-rf87"
]
},
"related_cves": [
{
"value": "CVE-2025-65105",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 356864,
"published_at": "2025-12-02T18:15:00+00:00"
}