UnratedFix available
openvpn — security advisory
OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.
- Products
- openvpn
- Affected versions
- Not specified
- Fixed versions
- 2.0.6-1
- CVEs
- CVE-2006-1629
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:12 UTC · Revision 1
Source evidence
OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.
osv:DEBIAN-CVE-2006-1629
openvpn
Fixed versions: 2.0.6-1
openvpn
Fixed versions: 2.0.6-1
openvpn
Fixed versions: 2.0.6-1
Complete source record
{
"id": "ae95f56fe0dc075af0ab78e8fb05df9f4ac88f0bd2a1c9792202c337c870380d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2006-1629",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2006-1629",
"summary": "OpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.",
"evidence": "osv:DEBIAN-CVE-2006-1629",
"products": [
{
"name": {
"value": "openvpn",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.6-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openvpn",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.6-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openvpn",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.6-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2006-1629",
"aliases": [
"DEBIAN-CVE-2006-1629"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.6-1"
}
]
}
],
"package": {
"name": "openvpn",
"purl": "pkg:deb/debian/openvpn?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-1629.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.6-1"
}
]
}
],
"package": {
"name": "openvpn",
"purl": "pkg:deb/debian/openvpn?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-1629.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.6-1"
}
]
}
],
"package": {
"name": "openvpn",
"purl": "pkg:deb/debian/openvpn?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-1629.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
}
],
"modified": "2026-10-22T23:47:24.081175108Z",
"provider": "osv",
"upstream": [
"CVE-2006-1629"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2006-1629"
]
},
"related_cves": [
{
"value": "CVE-2006-1629",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 410430,
"published_at": "2006-04-06T22:04:00+00:00"
}