Skip to content
Heist/ feed
Back to feed
Critical

WBCE CMS has Weak Random Number Generator in Password Generation Function

Type: advisorySources: OSV

WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-67504
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 15:20 UTC · Revision 1

Source evidence

WBCE CMS has Weak Random Number Generator in Password Generation Function

core-osv · Original source

Published 9 Dec 2025, 03:31 UTC

WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.

osv:CVE-2025-67504
Complete source record
{
  "id": "24f322cfe836f18f9f06b0f4afc5b3f98bba963c3a1167feac22ad96ff01978f",
  "url": "https://osv.dev/vulnerability/CVE-2025-67504",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WBCE CMS has Weak Random Number Generator in Password Generation Function",
    "summary": "WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.",
    "evidence": "osv:CVE-2025-67504",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2025-67504",
      "aliases": [
        "CVE-2025-67504",
        "GHSA-76gj-pmvx-jcc6"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wbce/wbce_cms",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "458d4385482770a7f6e77361e64265c1413b0c99"
                },
                {
                  "fixed": "5d59fe021a5c6e469b1bf192b72ca652e54278f6"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wbce:wbce_cms:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.6.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "5d59fe021a5c6e469b1bf192b72ca652e54278f6"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "458d4385482770a7f6e77361e64265c1413b0c99"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "1.6.5"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.6.4",
            "1.6.3",
            "1.6.2",
            "1.6.1",
            "1.6.0",
            "1.6.0-beta.4",
            "1.6.0-beta.2",
            "1.6.0-beta.1",
            "1.5.4",
            "1.5.3",
            "1.5.2",
            "1.5.1",
            "1.5.0",
            "1.4.0",
            "1.3.2",
            "1.3.1",
            "1.3.0",
            "1.2.0",
            "1.1.11",
            "1.1.10",
            "1.1.9",
            "1.1.8",
            "1.1.6",
            "1.1.4",
            "1.1.3",
            "1.1.2",
            "1.1.1",
            "1.1.0",
            "1.0.0",
            "1.0.0-rc.1",
            "1.0.0-beta.3",
            "1.0.0-beta.2",
            "1.0.0-beta.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-67504.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:51.101935553Z",
      "provider": "osv",
      "references": [
        "https://cwe.mitre.org/data/definitions/338.html",
        "https://github.com/WBCE/WBCE_CMS/releases/tag/1.6.5",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/67xxx/CVE-2025-67504.json",
        "https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-76gj-pmvx-jcc6",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-67504",
        "https://github.com/WBCE/WBCE_CMS/commit/5d59fe021a5c6e469b1bf192b72ca652e54278f6"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-331",
          "CWE-338"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/67xxx/CVE-2025-67504.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-67504",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 519741,
  "published_at": "2025-12-09T03:31:17.723+00:00"
}