MediumFix available
vim — security advisory
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 9.0.1499.
- Products
- vim
- Affected versions
- 2:8.2.2434-3ubuntu3, 2:8.2.2434-3ubuntu4, 2:8.2.3565-1ubuntu1, 2:8.2.3565-1ubuntu2, 2:8.2.3565-1ubuntu3, 2:8.2.3565-1ubuntu5, 2:8.2.3995-1ubuntu1, 2:8.2.3995-1ubuntu2, 2:8.2.3995-1ubuntu2.1, 2:8.2.3995-1ubuntu2.3, 2:8.2.3995-1ubuntu2.4, 2:8.2.3995-1ubuntu2.5, 2:8.2.3995-1ubuntu2.7
- Fixed versions
- 2:8.2.3995-1ubuntu2.8
- CVEs
- CVE-2023-2426
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:14 UTC · Revision 1
Source evidence
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 9.0.1499.
osv:UBUNTU-CVE-2023-2426
vim
Fixed versions: 2:8.2.3995-1ubuntu2.8
Complete source record
{
"id": "3cd0e91256bcb7f2bf324025d9c2e81cc1a7899541c31d45bac1579495e2d209",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2023-2426",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2023-2426",
"summary": "Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 9.0.1499.",
"evidence": "osv:UBUNTU-CVE-2023-2426",
"products": [
{
"name": {
"value": "vim",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:8.2.3995-1ubuntu2.8",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2:8.2.2434-3ubuntu3",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.2434-3ubuntu4",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3565-1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3565-1ubuntu2",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3565-1ubuntu3",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3565-1ubuntu5",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3995-1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3995-1ubuntu2",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3995-1ubuntu2.1",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3995-1ubuntu2.3",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3995-1ubuntu2.4",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3995-1ubuntu2.5",
"evidence": "/affected/0/versions"
},
{
"value": "2:8.2.3995-1ubuntu2.7",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2023-2426",
"aliases": [
"UBUNTU-CVE-2023-2426"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:8.2.3995-1ubuntu2.8"
}
]
}
],
"package": {
"name": "vim",
"purl": "pkg:deb/ubuntu/vim?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"2:8.2.2434-3ubuntu3",
"2:8.2.2434-3ubuntu4",
"2:8.2.3565-1ubuntu1",
"2:8.2.3565-1ubuntu2",
"2:8.2.3565-1ubuntu3",
"2:8.2.3565-1ubuntu5",
"2:8.2.3995-1ubuntu1",
"2:8.2.3995-1ubuntu2",
"2:8.2.3995-1ubuntu2.1",
"2:8.2.3995-1ubuntu2.3",
"2:8.2.3995-1ubuntu2.4",
"2:8.2.3995-1ubuntu2.5",
"2:8.2.3995-1ubuntu2.7"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2023/UBUNTU-CVE-2023-2426.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "vim",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-athena",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-common",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-gtk",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-gtk3",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-gui-common",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-nox",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-runtime",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "vim-tiny",
"binary_version": "2:8.2.3995-1ubuntu2.8"
},
{
"binary_name": "xxd",
"binary_version": "2:8.2.3995-1ubuntu2.8"
}
],
"availability": "No subscription required"
}
}
],
"modified": "2026-10-27T04:15:24.724499844Z",
"provider": "osv",
"upstream": [
"CVE-2023-2426"
],
"references": [
"https://ubuntu.com/security/CVE-2023-2426",
"https://huntr.dev/bounties/3451be4c-91c8-4d08-926b-cbff7396f425",
"https://github.com/vim/vim/commit/caf642c25de526229264cab9425e7c9979f3509b",
"https://ubuntu.com/security/notices/USN-6154-1",
"https://www.cve.org/CVERecord?id=CVE-2023-2426"
]
},
"related_cves": [
{
"value": "CVE-2023-2426",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 460167,
"published_at": "2023-04-29T22:15:00+00:00"
}